error: Installed distribution nose 0.9.2 conf

Help
2008-09-02
2012-12-15
  • Brian Brooks

    Brian Brooks - 2008-09-02

    Installing jcr-0.6.4 on ActiveState Python version 2.5.2.2

      ActivePython-2.5.2.2-win32-x86

    results the error message

    error: Installed distribution nose 0.9.2 conflicts with requirement nose>=0.9.3

    See details below.

    Any ideas?

    Brian

    ---- Begin Details----
    C:\tools\jcr-0.6.4>easy_install -f . jcr[sqlite]
    Searching for jcr[sqlite]
    Best match: jcr 0.6.4
    Processing jcr-0.6.4.egg
    creating c:\python25\lib\site-packages\jcr-0.6.4.egg
    Extracting jcr-0.6.4.egg to c:\python25\lib\site-packages
    Adding jcr 0.6.4 to easy-install.pth file

    Installed c:\python25\lib\site-packages\jcr-0.6.4.egg
    Processing dependencies for jcr[sqlite]
    Searching for pysqlite
    Reading http://pypi.python.org/simple/pysqlite/
    Reading http://pysqlite.org/
    Reading http://initd.org/pub/software/pysqlite/releases/2.3/2.3.3/
    Reading http://pysqlite.sourceforge.net/
    Reading http://initd.org/pub/software/pysqlite/releases/2.3/2.3.5/
    Reading http://oss.itsystementwicklung.de/trac/pysqlite
    Reading http://oss.itsystementwicklung.de/download/pysqlite/2.4/2.4.1/
    Reading http://initd.org/tracker/pysqlite/wiki/PysqliteDownloads
    Reading http://initd.org/pub/software/pysqlite/releases/2.4/2.4.0/
    Reading http://initd.org/pub/software/pysqlite/releases/2.3/2.3.4/
    Best match: pysqlite 2.4.1
    Downloading http://oss.itsystementwicklung.de/download/pysqlite/2.4/2.4.1/pysqli
    te-2.4.1.win32-py2.5.exe
    Processing pysqlite-2.4.1.win32-py2.5.exe
    WARNING: can't process DATA/pysqlite2-doc/install-source.html
    WARNING: can't process DATA/pysqlite2-doc/install-source-win32.html
    WARNING: can't process DATA/pysqlite2-doc/usage-guide.html
    WARNING: can't process DATA/pysqlite2-doc/install-source-win32.txt
    WARNING: can't process DATA/pysqlite2-doc/install-source.txt
    WARNING: can't process DATA/pysqlite2-doc/usage-guide.txt
    WARNING: can't process DATA/pysqlite2-doc/silvercity.css
    WARNING: can't process DATA/pysqlite2-doc/default.css
    WARNING: can't process DATA/pysqlite2-doc/docutils.css
    creating 'c:\docume~1\bb185056\locals~1\temp\easy_install-evftp1\pysqlite-2.4.1-
    py2.5-win32.egg' and adding 'c:\docume~1\bb185056\locals~1\temp\easy_install-evf
    tp1\pysqlite-2.4.1-py2.5-win32.egg.tmp' to it
    Moving pysqlite-2.4.1-py2.5-win32.egg to c:\python25\lib\site-packages
    Adding pysqlite 2.4.1 to easy-install.pth file

    Installed c:\python25\lib\site-packages\pysqlite-2.4.1-py2.5-win32.egg
    Searching for AuthKit>=0.4
    Reading http://pypi.python.org/simple/AuthKit/
    Reading http://authkit.org/
    Reading http://3aims.com/
    Reading http://pylonshq.com/
    Best match: AuthKit 0.4.0
    Downloading http://pypi.python.org/packages/source/A/AuthKit/AuthKit-0.4.0.tar.g
    z#md5=c908e41f82a0821e6fe7d2c838269692
    Processing AuthKit-0.4.0.tar.gz
    Running AuthKit-0.4.0\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\loca
    ls~1\temp\easy_install-rqmqp5\AuthKit-0.4.0\egg-dist-tmp-lsvx_p
    Adding authkit 0.4.0 to easy-install.pth file

    Installed c:\python25\lib\site-packages\authkit-0.4.0-py2.5.egg
    Searching for SQLAlchemy>=0.4,<=0.4.9
    Reading http://pypi.python.org/simple/SQLAlchemy/
    Reading http://www.sqlalchemy.org
    Best match: SQLAlchemy 0.4.7p1
    Downloading http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.4.7
    p1.tar.gz#md5=5657ace9ed484429486b24e4b6e6f1ad
    Processing SQLAlchemy-0.4.7p1.tar.gz
    Running SQLAlchemy-0.4.7p1\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056
    \locals~1\temp\easy_install-kiznsy\SQLAlchemy-0.4.7p1\egg-dist-tmp-t9azgw
    zip_safe flag not set; analyzing archive contents...
    sqlalchemy.databases.mysql: module MAY be using inspect.stack
    Adding sqlalchemy 0.4.7p1 to easy-install.pth file

    Installed c:\python25\lib\site-packages\sqlalchemy-0.4.7p1-py2.5.egg
    Searching for Beaker>=0.8.1
    Reading http://pypi.python.org/simple/Beaker/
    Reading http://beaker.groovie.org
    Best match: Beaker 1.0.1
    Downloading http://pypi.python.org/packages/2.5/B/Beaker/Beaker-1.0.1-py2.5.egg#
    md5=ea4b413984e41218cc7b5bb000769e26
    Processing Beaker-1.0.1-py2.5.egg
    creating c:\python25\lib\site-packages\Beaker-1.0.1-py2.5.egg
    Extracting Beaker-1.0.1-py2.5.egg to c:\python25\lib\site-packages
    Adding Beaker 1.0.1 to easy-install.pth file

    Installed c:\python25\lib\site-packages\beaker-1.0.1-py2.5.egg
    Searching for Pylons>=0.9.6,<=0.9.6.9
    Reading http://pypi.python.org/simple/Pylons/
    Reading http://www.pylonshq.com/
    Reading http://pylons.groovie.org/
    Best match: Pylons 0.9.6.2
    Downloading http://pypi.python.org/packages/2.5/P/Pylons/Pylons-0.9.6.2-py2.5.eg
    g#md5=d77d57de37d6ba1cb3bb743b22996e29
    Processing Pylons-0.9.6.2-py2.5.egg
    creating c:\python25\lib\site-packages\Pylons-0.9.6.2-py2.5.egg
    Extracting Pylons-0.9.6.2-py2.5.egg to c:\python25\lib\site-packages
    Adding Pylons 0.9.6.2 to easy-install.pth file

    Installed c:\python25\lib\site-packages\pylons-0.9.6.2-py2.5.egg
    Reading http://www.pylonshq.com/download/
    Searching for decorator>=2.1.0
    Reading http://pypi.python.org/simple/decorator/
    Reading http://www.phyast.pitt.edu/~micheles/python/documentation.html
    Best match: decorator 2.3.1
    Downloading http://www.phyast.pitt.edu/~micheles/python/decorator-2.3.1.zip
    Processing decorator-2.3.1.zip
    Running setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\locals~1\temp\easy
    _install-u1rcno\egg-dist-tmp-_epogq
    Adding decorator 2.3.1 to easy-install.pth file

    Installed c:\python25\lib\site-packages\decorator-2.3.1-py2.5.egg
    Searching for elementtree>=1.2,<=1.3
    Best match: elementtree 1.2.6-20050316
    Downloading http://pylons.cachefly.net/download/0.9.6.2/elementtree-1.2.6-200503
    16.tar.gz
    Processing elementtree-1.2.6-20050316.tar.gz
    Running elementtree-1.2.6-20050316\setup.py -q bdist_egg --dist-dir c:\docume~1\ bb185056\locals~1\temp\easy_install-qura_r\elementtree-1.2.6-20050316\egg-dist-t
    mp-1a5qo1
    zip_safe flag not set; analyzing archive contents...
    Adding elementtree 1.2.6-20050316 to easy-install.pth file

    Installed c:\python25\lib\site-packages\elementtree-1.2.6_20050316-py2.5.egg
    Searching for python-urljr==1.0.0,<=1.1
    Reading http://pypi.python.org/simple/python-urljr/
    Reading http://www.openidenabled.com/openid/libraries/python/
    Reading http://openidenabled.com/python-openid/
    Best match: python-urljr 1.0.1
    Downloading http://openidenabled.com/files/python-openid/files/python-urljr-1.0.
    1.tar.gz
    Processing python-urljr-1.0.1.tar.gz
    Running python-urljr-1.0.1\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056
    \locals~1\temp\easy_install-ffxmwa\python-urljr-1.0.1\egg-dist-tmp-jyfycx
    zip_safe flag not set; analyzing archive contents...
    Adding python-urljr 1.0.1 to easy-install.pth file

    Installed c:\python25\lib\site-packages\python_urljr-1.0.1-py2.5.egg
    Searching for python-yadis==1.0.1,<=1.1
    Best match: python-yadis 1.1.0
    Downloading http://openidenabled.com/files/python-openid/files/python-yadis-1.1.
    0.tar.gz
    Processing python-yadis-1.1.0.tar.gz
    Running python-yadis-1.1.0\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056
    \locals~1\temp\easy_install-0fklyi\python-yadis-1.1.0\egg-dist-tmp-r--ekv
    zip_safe flag not set; analyzing archive contents...
    Adding python-yadis 1.1.0 to easy-install.pth file

    Installed c:\python25\lib\site-packages\python_yadis-1.1.0-py2.5.egg
    Searching for python-openid>=1.1,<=1.2
    Best match: python-openid 1.2.0
    Downloading http://openidenabled.com/files/python-openid/packages/python-openid-
    1.2.0.zip
    Processing python-openid-1.2.0.zip
    Running python-openid-1.2.0\setup.py -q bdist_egg --dist-dir c:\docume~1\bb18505
    6\locals~1\temp\easy_install-ymqj9s\python-openid-1.2.0\egg-dist-tmp-dd2-c-
    warning: no files found matching 'README' under directory 'examples'
    warning: no files found matching 'dhpriv' under directory 'openid\test'
    warning: no files found matching 'linkparse.txt' under directory 'openid\test'
    warning: no files found matching 'n2b64' under directory 'openid\test'
    warning: no files found matching 'trustroot.txt' under directory 'openid\test'
    zip_safe flag not set; analyzing archive contents...
    Adding python-openid 1.2.0 to easy-install.pth file

    Installed c:\python25\lib\site-packages\python_openid-1.2.0-py2.5.egg
    Searching for PasteScript>=1.1
    Best match: PasteScript 1.3.6
    Downloading http://pylons.cachefly.net/download/0.9.6.2/PasteScript-1.3.6.tar.gz

    Processing PasteScript-1.3.6.tar.gz
    Running PasteScript-1.3.6\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\ locals~1\temp\easy_install-wq-vsk\PasteScript-1.3.6\egg-dist-tmp-opkw-2
    Adding pastescript 1.3.6 to easy-install.pth file
    Installing paster script to C:\Python25\Scripts
    Installing paster-script.py script to C:\Python25\Scripts
    Installing paster.exe script to C:\Python25\Scripts

    Installed c:\python25\lib\site-packages\pastescript-1.3.6-py2.5.egg
    Searching for PasteDeploy>=1.1
    Best match: PasteDeploy 1.3.1
    Downloading http://pylons.cachefly.net/download/0.9.6.2/PasteDeploy-1.3.1.tar.gz

    Processing PasteDeploy-1.3.1.tar.gz
    Running PasteDeploy-1.3.1\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\ locals~1\temp\easy_install-4553dh\PasteDeploy-1.3.1\egg-dist-tmp-cfein3
    warning: no files found matching 'docs\*.html'
    warning: no previously-included files found matching 'docs\rebuild'
    Adding pastedeploy 1.3.1 to easy-install.pth file

    Installed c:\python25\lib\site-packages\pastedeploy-1.3.1-py2.5.egg
    Searching for nose>=0.9.2
    Best match: nose 0.9.2
    Downloading http://pylons.cachefly.net/download/0.9.6.2/nose-0.9.2.tar.gz
    Processing nose-0.9.2.tar.gz
    Running nose-0.9.2\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\locals~
    1\temp\easy_install-nbxmtt\nose-0.9.2\egg-dist-tmp-2czb-r
    warning: no files found matching 'unit_tests\*\*\*\*\*.py'
    zip_safe flag not set; analyzing archive contents...
    nose.importer: module references __file__
    nose.importer: module references __path__
    nose.inspector: module MAY be using inspect.findsource
    nose.loader: module references __file__
    nose.loader: module references __path__
    nose.selector: module references __file__
    nose.suite: module references __path__
    nose.util: module references __file__
    nose.plugins.cover: module references __file__
    Adding nose 0.9.2 to easy-install.pth file
    Installing nosetests-script.py script to C:\Python25\Scripts
    Installing nosetests.exe script to C:\Python25\Scripts

    Installed c:\python25\lib\site-packages\nose-0.9.2-py2.5.egg
    Searching for Paste>=1.4
    Best match: Paste 1.4.2
    Downloading http://pylons.cachefly.net/download/0.9.6.2/Paste-1.4.2.tar.gz
    Processing Paste-1.4.2.tar.gz
    Running Paste-1.4.2\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\locals
    ~1\temp\easy_install-iagdht\Paste-1.4.2\egg-dist-tmp-pafy0y
    Adding paste 1.4.2 to easy-install.pth file

    Installed c:\python25\lib\site-packages\paste-1.4.2-py2.5.egg
    Searching for Mako>=0.1.8
    Best match: Mako 0.1.8
    Downloading http://pylons.cachefly.net/download/0.9.6.2/Mako-0.1.8.tar.gz
    Processing Mako-0.1.8.tar.gz
    Running Mako-0.1.8\setup.py -q bdist_egg --dist-dir c:\docume~1\bb185056\locals~
    1\temp\easy_install-qtvwzh\Mako-0.1.8\egg-dist-tmp-ev3h8-
    Adding mako 0.1.8 to easy-install.pth file

    Installed c:\python25\lib\site-packages\mako-0.1.8-py2.5.egg
    error: Installed distribution nose 0.9.2 conflicts with requirement nose>=0.9.3

    C:\tools\jcr-0.6.4>

     
    • Brian Brooks

      Brian Brooks - 2008-09-02

      The following may have resolved this issue...

      C:\tools\jcr-0.6.4>easy_install -U nose

      Brian

       
    • John Dickson

      John Dickson - 2008-09-02

      Yes, that's exactly the right way to deal with the issue.

      Unfortunately, I still don't know why easy_install sometimes chooses the earliest matching version of a required library, as happened here:

          Searching for nose>=0.9.2
          Best match: nose 0.9.2

      Cheers ......................... JD

       

Log in to post a comment.