JavaScript Lint from svn (Linux)

  • inghamc

    inghamc - 2009-10-02

    I've switched from Windows to Kubuntu since my last heavy JavaScript development, and of course wanted to use JavaScript Lint!  When given the choice between the tar.gz'd source or svn-direct, I thought "What the heck - this way I'll pick up anything new if/when that happens…"  What a pleasant surprise to find new goodies in there!

    I did have issues, however:

    - **Command line wrapper?**

    Though I'm no *nix ninja, I knew enough to follow INSTALL, which gave me a working  I naively tried copying this to my ~/bin directory and quickly found that a no-go.  I then tried various invocations of install with -prefix, -home, -user, etc.  I tried **-dry-run** with these and found it to be pretty wet (**defect: lib directories got created anyway**).

    I'm only a  programmer: Your modern lib/python/2.6/site-packages and .egg-info files frighten and confuse me…  But I **do** know the Windows executable hid all that from me and gave me a nice, reassuring "0 errors" ouput when I behaved myself, and surely a project implemented in nice, portable Python and C couldn't have only a Win32 API dependent command line executable?

    For now I ended up writing a jsl bash script to invoke my svn workspace's with my edited .conf file, but would love the same wrapper I got spoiled with on Windows…

    - **New (secret) Warnings**

    Actually I'll make a separate post for this…


  • Matthias Miller

    Matthias Miller - 2009-10-03

    Yes, I've just been working out the trunk, so I got lazy with proper packaging/installation.

    However, try it now. Update from Subversion and reinstall. (You don't need to run the makefile anymore. Just use


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks