Memory issue while doing Flush() in CallTracer WAR application

Suresh
2014-01-23
2014-01-27
  • Suresh

    Suresh - 2014-01-23

    Hi,
    I am using JavaCallTracer 1.4.1 and deployed the CallTracer War in Tomcat server 6.0.

    I did the following steps to capture the calltrace of my web application:
    1. Set the required VM arguments in Tomcat server.
    2. Run CallTracer war. Clicked 'START' button.
    3. Performed some activities on my application deployed in same server.
    4. Clicked "STOP" buttion in CallTracer War.
    5. Clicked "PRINT TRACE" in CallTracer war app. It displays the XML format Trace data in the text box below.
    6. Clicked "FLUSH" button.
    6. Again clicked "START" button, performed some activities on my application, Click "STOP", then clicked "PRINT TRACE". This gives me below error in server console.

    Doing action :Stop
    Doing action :Print Trace

    A fatal error has been detected by the Java Runtime Environment:

    EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x641c2b64, pid=11660, tid=11620

    JRE version: 6.0_26-b03
    Java VM: Java HotSpot(TM) Client VM (20.1-b02 mixed mode windows-x86 )
    Problematic frame:
    C [calltracer5.dll+0x2b64]

    An error report file with more information is saved as:
    D:\Suresh\Projects\EclipseHelios\eclipseIms\hs_err_pid11660.log

    The error log file "hs_err_pid11660.log" has following contents:

    Stack: [0x18cf0000,0x18d40000], sp=0x18d3f220, free space=316k
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
    C [calltracer5.dll+0x2b64]
    C [calltracer5.dll+0x2cb5]
    C [calltracer5.dll+0x2ea4]
    C [calltracer5.dll+0x328f] Java_com_calltracer_jni_CallTracerJNI_printTrace+0x11
    j com.calltracer.jni.CallTracerJNI.printTrace()Ljava/lang/String;+0
    J com.calltracer.action.CallTracerAction.execute>(Lorg/apache/struts/action/ActionMapping;Lorg/apache/struts/action/ActionForm;Ljavax/servlet/http/Http>ServletRequest;Ljavax/servlet/http/HttpServletResponse;)Lorg/apache/struts/action/ActionForward;

    Can you let me know why after doing FLUSH command, the CallTracer War fails to print tracing?

    Thanks and Regards
    Suresh

     
  • Syed Ali Naqvi

    Syed Ali Naqvi - 2014-01-23

    Check if you have permissions to writing to the trace file from Tomcat. Simple way to do that will be to write a file writing java code in a servlet and hit it from your browser after deployment.

     
  • Suresh

    Suresh - 2014-01-24
    Post awaiting moderation.
  • Syed Ali Naqvi

    Syed Ali Naqvi - 2014-01-25

    That might be a bug, I will check the code and get back.

     
  • Syed Ali Naqvi

    Syed Ali Naqvi - 2014-01-25

    I think I have solved the bug. I can send you the updated source files, but you will have to compile it at your end. I am attaching the updated source files here.

    Officially releasing the fix might take some time. Let me know if the solution worked for you.

     
  • Suresh

    Suresh - 2014-01-27
    Post awaiting moderation.
  • Syed Ali Naqvi

    Syed Ali Naqvi - 2014-01-27

    Hi Suresh,
    Glad to help. If you don't mind can you attach the DLL in this thread.

    Thanks.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks