When doing a bulk upload, I had copied and pasted a bunch of emails, of which happened to be formatted with upper/lower case. These emails did not load, and reported an error. But when I reentered these emails as lowercase only, they all loaded fine. Eg. Lyn.Evans@cern.ch would not load, but lyn.evans@cern.ch was fine.