Win2003 64 bit - ComFailException - MSJava

Anonymous
2009-01-26
2013-05-20
  • Anonymous - 2009-01-26

    Hye,

    I'm trying to use JACOB (1.14.3) on a Windows 2003 Server - 64 bit.

    When running, I get following error: com.jacob.com.ComFailException: Can't co-create object

    If I run the dependency walker, I see that it gives an error on the MSJAVA.DLL which can only be found for 32bits...

    Anyone has an idea how I can get this working on Win2003 - 64 bit ? or how this dependency to MSJava.dll can be removed..?

    Other ideas about how to detect what co-creation is going wrong is also very much appreciated.

    Thanks in advance,
    Steven

     
    • clay_shooter

      clay_shooter - 2009-06-06

      Is MSJAVA.DLL a microsoft library or a sun library? 

      Do you have the 64 bit JDK installed?  64 bit OS can run either 32 bit or 64 bit Java VMs.

       
  • lvqing

    lvqing - 2011-07-27

    Hi,I tell you the same mistake, don't know you been solved
    com.jacob.com.ComFailException: Can't co-create object 
    at com.jacob.com.Dispatch.createInstanceNative(Native Method)
    at com.jacob.com.Dispatch.<init>(Dispatch.java:101)
    at com.jacob.activeX.ActiveXComponent.<init>(ActiveXComponent.java:58)
    at com.dheaven.mip.protocol.dps.office.WindowsFile$1.call(WindowsFile.java:118)
    at com.dheaven.mip.protocol.dps.office.WindowsFile$1.call(WindowsFile.java:1)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
    at java.lang.Thread.run(Thread.java:662)

     
  • clay_shooter

    clay_shooter - 2012-04-25

    Some libraries are only 32 bit.

    I can't remember if you can override the 64 bit JVM to use the 32 bit JNI dll in place of the default 64 bit JNI dll.  I think this was discussed somewhere else.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks