#65 rc5 vc6 compile bugs

closed-wont-fix
nobody
None
5
2009-06-27
2005-08-10
n_toze
No

source\c++\lib\win32\vc++6.0\jace.dsp doesn't define
JACE_EXPORTS and doesn't include
WrapperVmLoader.cpp (only vc++7.1 vbproj file seems
to do this).

When I build my peer code in vc6, I have to comment
out the '__declspec(dllimport)' in the JACE_EXPORTS
section in os_dep.h, otherwise vc6 complains about
inconsistent export decs (lnk4049) and unresolved
external symbols.

Discussion

  • n_toze

    n_toze - 2005-08-15

    Logged In: YES
    user_id=1114997

    It seems that we need the __declspec(dllimport) when linking
    with jace.dll, but not when jace is compiled as a static library.
    Probably would be good if the download has all the vc++6
    stuff as a dll rather then a static library, and then include
    some notes on how to use jace as a static library.

     
  • Gili Tzabari

    Gili Tzabari - 2009-06-27

    VC++ 6.0 is no longer supported.

     
  • Gili Tzabari

    Gili Tzabari - 2009-06-27
    • status: open --> closed-wont-fix
     

Log in to post a comment.