New debug version

2005-02-17
2013-04-15
1 2 3 > >> (Page 1 of 3)
  • Micheal Lloyd Lee

    OK, I've sent the last few hours getting the basics for my new, simplified input system ready. This is due in part due to the problems people are having on BBs, and part due to the problems I'm having on my Sendo M570 (two sides of the same coin). I've also been playing with a few things so it might be fixed for the "Attribute Mismatch" bug, and the SonyEricsson k700i bug (I think it is the same bug).

    I still have a lot left to do, my current plan is to add a new conf system in the about screen.

    You can grab the beta
    http://j2mevnc.sf.net/downloads/VNCdebug.jad
    http://j2mevnc.sf.net/downloads/VNCdebug.jar

    The inpu tsystem has been greatly simplified, you now only have one input mode (rather than a "game keys" mode and a "number keys" mode.) This can be changed either in the options menu, or via the star (*) key. The four modes are:
    Nav  -  Direction buttons (and 2,4,6,8) move the screen
    Mouse - Direction buttons (and 2,4,6,8) move the mouse, fire (and 5 ) fires, GAME_A ( or #) double clicks.
    SMS - Uses my bad SMS implementation
    Type - Will send the chars as - is. Like Numlock mode of 3.0.4.

    I've quite a bit left to do before it is finished, but I'd like to know what you all think. Is splitting the modes a Good Thing(tm)?
    I would like to make it user-expandable, but doing this in a clean, and lite way is not looking hopeful.

    Mike

     
    • geeknik

      geeknik - 2005-02-17

      Works fine on my Sprint PCS Treo 650 w/ IBM's WebSphere Everyplace Micro Environment JVM.  Albeit it's rather slow since Sprint's 3G network sucks, but it works better then it did on my last phone. :)

       
    • Nobody/Anonymous

      New to this and not sure how to compile this to work on my blackberry 7290.  I installed the RIM Development Environment but what do i do with the file i downloaded.

      Brian

       
    • Nobody/Anonymous

      Any info on the 907 Invalid JAR error? Using a BB 7250.

       
      • Micheal Lloyd Lee

        You are still getting it with the latest version? Mmm...

         
    • Nobody/Anonymous

      hi,
         I am a unversity student who is preparing a graduation project just like j2meVNC. But I could'nt find many useful articles and ebooks.
        A little help from those who are interested in this project, or who knows any paper which can be of use will be greatly appretiated.

      Please contact me at:
      deniz_isik82@yahoo.ca

       
    • Nobody/Anonymous

      Had no chance get it to work on my 9500 :((. It runs, connects to the server, but there's no way to use mouse mode properly - arrow keys (neither 2,4,6,8) are not functional. Any ideas?

       
      • Arendt David

        Arendt David - 2005-04-05

        Some thing here with my 9500. Would be nice if you could get this working. I think you would make a lot of people happy :-)

         
        • Micheal Lloyd Lee

          Do the other modes work?

           
    • Arendt David

      Arendt David - 2005-04-06

      Yes, it seems only mouse control is not working. In fact it seems like mouse events are generated but the pointer does n't move. Sometimes it does a jump in the upper left edge.

       
      • Nobody/Anonymous

        Can you try local curser mode.
        Plus, as I don't know where the mouse curser is, it does default to top left, so try using Call Mouse before moving it.

         
    • Nobody/Anonymous

      Trying this on my E398, loads fine, gets a connection (I can see my server-icon turns black) but the screen on the phone is also nothing but black. (no, not gray or white/black pattern, I see that when scrolling but the normal desktop is black black and black)

      NCM doesnt help. Any ideas? I see nothing of interest in the log.

       
      • Nobody/Anonymous

        It also doesnt get me any error-messages.

         
    • Nobody/Anonymous

      I can't use http proxy function,it prompt "the requedted protocol is not exiest,why?

       
    • Nobody/Anonymous

      On my 9500 I can't even move mouse anywhere - even to the upper left corber ;(

       
    • Nobody/Anonymous

      Hi, I've got a Sanyo MM7400 (On the Sprint Network). Unfortunately, I still get the "Attribute Mismatched" error.

       
    • Nobody/Anonymous

      I have got this running very nicely on a nokia 9300. the trick is to switch between the modes and to use the "get mouse cursor " thing often. It works really well, although of course on a small screen I reckon any VNC type application should be emergencies only :-) I have a couple of cool photos, but don't know how to download them. Please feel free to email me, Michael, if you would like to display them. Very nice work, mate. Well done.

       
    • Nobody/Anonymous

      I have got this running very nicely on a nokia 9300. the trick is to switch between the modes and to use the "get mouse cursor " thing often. It works really well, although of course on a small screen I reckon any VNC type application should be emergencies only :-) I have a couple of cool photos, but don't know how to download them. Please feel free to email me, Michael, if you would like to display them. Very nice work, mate. Well done. - my email is vnc_sourceforge@caspost.co.uk

       
    • Nobody/Anonymous

      The new debug version 3.0.5 mode switching method using ^ has simplifed the input so much. I love it.

      Elton

       
    • Nobody/Anonymous

      Mike,

      Is there an easy way in J2ME to determine the language setting of the mobile device an app is running on?  I envision a system property-like variable which can be accessed to discover the language.

      thanks,

      r

       
    • Nobody/Anonymous

      For us non techie people that  do not know how to convert jad or jar files to cod ones, can you allow us to download cod files please.

       
    • Nobody/Anonymous

      HI, I'm running from nokia 6630 and have installed the above jar file.  On the other side I have a Win2k server with VNC4 installed and working through java client.  This sits behind a firewall with has port forwarding enabled and pointing all traffic for port 7771 to this server.

      When trying to connect to external IP xxx.xxx.xxx.xxx:7771 the connection bar moves very quicky until the end where it sits for a while and returns the error "not a VNC server".

      This works fine using an external PC.  Do I need to install any additional software/ use a specific port?

       
    • Bakkulf

      Bakkulf - 2005-09-13

      To you with Nokia 6630; this app supports only native VNC traffic, not the Java-client over HTTP as far as I know. Set up another port forward as well; eg. 7772 -> your server:5801. But; I'm not sure if this client allows you to specify other sending ports either... Anyone?

       
    • Bakkulf

      Bakkulf - 2005-09-13

      I just posted a note about an error message I get using this beta (and older versions as well);
      The message is on the format "Server Sent Unknown Encoding! Update:-239", but with different numbers after the "Update:"-part.

      A more thorough description (+ error log) is posted here:
      https://sourceforge.net/forum/forum.php?thread_id=1288023&forum_id=262224

       
1 2 3 > >> (Page 1 of 3)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks