J2ME VNC over HttpTunnel

2005-02-15
2013-04-15
  • Atsuhiko Yamanaka

    Hi there,

    I'm developing jhttptunnel[1] and, in these days, I have been trying to port it to MIDP platform.
    Today, I applied this hack to J2ME VNC and it seems
    that it works on MIDP emulator included in Wireless Toolkit 2.2.  I want to know if it really works on real devices.  If you are interested in this hack, please try it on your devices and write jhttptunnel@jcraft.com the feedback.

    To try this stuff, apply the patch[2] and comiple
    the J2ME VNC source code with JHttpTunnel 0.0.3[3].  Before starting this midlet, you have to
    run 'hts -F vncserver:590X' on the remote. The 'hts' command is from HttpTunnel 3.0.5[4] with some patch[5]. For your conveniences, there are jad and jar files on [1].

    Thanks,

    [1] http://www.jcraft.com/jhttptunnel/
    [2] http://www.jcraft.com/jhttptunnel/j2mevnc-20050215.patch
    [3] http://www.jcraft.com/jhttptunnel/jhttptunnel-0.0.3.zip
    [4] http://www.nocrew.org/software/httptunnel.html
    [5] http://www.jcraft.com/jhttptunnel/httptunnel-3.0.5-0.0.3.patch

     
    • Micheal Lloyd Lee

      Great stuff! :)
      If your ever in London, give me a shout, and I'll buy you a pint :)

      Looking over the .jad file, it seams to require MIDP2. Where does this requirement come from, and can it be removed?
      Looking over the httptunnel, I can't work out if it requires a pernamently open connection to the J2ME client.

      I'm going to have to look into rewriting my build script cos of you, add conditional building of SSH & httptunnelling. :D

       
    • Atsuhiko Yamanaka

      > Looking over the .jad file, it seams to require
      > MIDP2. Where does this requirement come from,
      > and can it be removed?

      Ok, I have changed the Target platform as 'MIDP1.0'
      and recompiled it without any errors.  It seems it works. I have updated jar and jad files on http://www.jcraft.com/jhttptunnel/  .

       
      • Micheal Lloyd Lee

        Hi, I can conferm that it works on a real device (yeay!) namely my Sendo M570. I think it was a little slower than socket, but it worked. It also took quite some time to exit, but I think this is actually down to me. I've put it into the CVS.

         
        • Atsuhiko Yamanaka

          Thank you for feedback!
            > Hi, I can conferm that it works on a real device
            > (yeay!) namely my Sendo M570.
          Which network operator are you using?
          I'm interested in if there exist operators who reject to run jhttptunnel.

           
          • Nobody/Anonymous

            I'm using Vodafone UK.

             
    • Nobody/Anonymous

      I'm running the Sony Ericsson T637 and I get this error:

      #unknown_problem#-
      java.io.IOException: g:
      java.io.IOException

      When I get this error all I can do is click Ok and then it returns me to the main screen, so I can't upload the log.  If I run Log instead of connect it says "NOT STARTED TO LO" at the top and gives me just a blank screen.  If I hit "More" I can Upload but as soon as I click Upload it says "Application error." on my device and then closes the program.  That doesn't really bother me it's just that I can't upload the log for diagnosing.

      -z0rz

       
    • Nobody/Anonymous

      i m narottam agarwala

      i tried it on Nokia 3200 (MIDP 1.0)

      i got the error :
      #unknown_problem#
      - java.io.IOException: g: java.io.IOException

       
      • Nobody/Anonymous

        got the same here with Nokia 3120 (S40, MIDP1)

        --Fabiano

         
    • Nobody/Anonymous

      same on t610

       
    • Alex Stumpf

      Alex Stumpf - 2005-05-03

      Hi!
      I tried the new version on my T610
      set up hts on the same server vncserver is running on:
      hts -F 127.0.0.1:5905 7305

      then set the midlet's httpproxy to
      http://myserver:7305

      I'm not so sure why I still have to set a host in the midlet's config (since it's already set in the hts command) but tried both myserver:5 and 127.0.0.1:5.

      When I hit connect, the progress bar goes slowly up to 100% and the log sais

      Connecting
      Connecting Use HTTP Socket
      Connection Open
      Creating VNC Canvas 9 8
      .
      .
      .
      run started
      init
      -------------------

      after that nothing happens.

      Any suggestions?

      Thanks,
      Alex

      PS: It seems The attribute "use Http proxy" is not saved into RMS. After a midlet restart and a connect to the server, "socket://..." is used again.

       
    • Nobody/Anonymous

      hello it is good

       
    • Nobody/Anonymous

      I am trying to find a VNC client for my verizon 7750 Blackberry.

      Am I in the right place?

      kevin.berry@suntrust.com

       
    • Nobody/Anonymous

      Hi, I'm looking for a client that will work on my Nokia 6630 through a standard prepay internet connection and connect to my network servers using VNC.  I'm a complete newbie when it comes to software (other than using it) and I'm a bit stuck with the directions on this.  Does anyone have a complete jar that I can download and will work as installed?

      Help on this would be greatly appreciated.

      burden010@yahoo.com

       
  • Alex Stumpf

    Alex Stumpf - 2005-05-19

    * 'hts -F 127.0.0.1:5905 7305' should be
    'hts -F 127.0.0.1:5905' or 'hts -F 127.0.0.1:5905 8888'

    Why should I be forced to use port 8888? I don't think this is a necessity since I use port 7305 both on the httptunnel-server and in the midlet's http-proxy settings

    * check 'jhttptunnel'
    * you don't have to set midlet's httpproxy .

    Isn't this the same?!? I only have the possibility to set a http-proxy which I assume to be the tunneling-server. There is no "jhttptunnel" setting in my midlet. Seems I used an old version?!?
    Will report back here once get the chance to test some more...

    - Alex

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks