mo-weigand - 2013-05-16


I'm running an OPC DCOM Server and trying to connect to it from the same machine. I can easily connect with the MatrikonOPCExplorer (e.g.) but if I try to setup a connection with j-interop the JIException throws "Access is denied. [0x80070005]". The Authentication information are right but I get this error.

Now if I change my login settings to something obviously wrong, JIException throws a different Error:
"Access is denied, please check whether the [domain-username-password] are correct. Also, if not already done please check the GETTING STARTED and FAQ sections in readme.htm. They provide information on how to correctly configure the Windows machine for DCOM access, so as to avoid such exceptions. [0x00000005]"

What's the difference and how can I get rid of these errors? The Permission settings in the registry and in the dcomcnfg seem to be right. I first tried to set them to be accessed by "Everyone", then I changed them to my own user....but nothing worked.

Thanks in advance!