Windows 2003 x64 DCOM configuration problem

krsv
2012-03-22
2012-11-29
  • krsv

    krsv - 2012-03-22

    I am trying to connect to the dll library installed on Windows Server 2003 x 64 via J-Interop 2.0.8 from my local machine.

    The configuration details/steps that have been made:
    - I have installed the dll using regsvr32. On this step I am able to call the dll directly from the Windows x 64 machine. But when I try to connect to it via J-Interop, I got the error

    Class not registered. If you are using a DLL/OCX , please make sure it has "DllSurrogate" flag set

    My code is

                [b]JISystem.setAutoRegisteration(true);[/b]
                JISession session = JISession.createSession("...", "...", "...");
                JIComServer comServer = new JIComServer(JIProgId.valueOf("..."), "...", session);
    

    - I have performed the configuration steps from the http://www.j-interop.org/faq.html#A6, http://support.microsoft.com/kb/198891/en-us, section - Modify registry to force remoting of the object - I have tried the easy way and the hard way (using oleviewer and manually adjusting the register entries). The register entries for the dll are set up according to these instructions (CLSID, AppID, DllSurrogate flag). I have checked that the permissions for the corresponding CLSID/AppID are set up correctly for the corresponding user for remote access.
    But I still got the same error when I try to create a JIComServer instance.

    Are there any additional configuration steps to be done?
    Are there any utilities tools to check what is wrong with the dll / DCOM configuration?
    Any help will be appreciated. Thanks!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks