Class not registered. If you are using a DLL/OCX , please make sure it has "DllSurrogate" flag set

Deepak
2014-01-09
2014-01-15
  • Deepak

    Deepak - 2014-01-09

    I have been trying to get over this message for last one week but all in vain. The machine is on a domain, OS is windows server 2008 and I am trying with localhost (though tried multiple combination of domains also). Using the simple new JIComServer(JIProgId.valueOf("WbemScripting.SWbemLocator"),hostIP,dcomSession); and can't get passed out of it.

     
    • Vikram Roopchand

      Hi,

      This is a registration issue. On 2K8 you will have to register manually.
      Permission issues will make Auto Registration fail.

      best regards,
      Vikram

      On Fri, Jan 10, 2014 at 12:57 AM, Deepak deepakagarwal@users.sf.net wrote:

      I have been trying to get over this message for last one week but all in
      vain. The machine is on a domain, OS is windows server 2008 and I am trying
      with localhost (though tried multiple combination of domains also). Using
      the simple new
      JIComServer(JIProgId.valueOf("WbemScripting.SWbemLocator"),hostIP,dcomSession);
      and can't get passed out of it.


      Class not registered. If you are using a DLL/OCX , please make sure it has
      "DllSurrogate" flag sethttps://sourceforge.net/p/j-interop/discussion/840678/thread/8aff0f8c/?limit=25#b01f


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/j-interop/discussion/840678/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

      --
      The Mind is a place of its own. It can make a heaven out of hell or a hell
      out of heaven. Attitude is everything. No matter how adverse conditions
      maybe, one has the capacity to turn things around by one's Determination,
      Perseverance and Hardwork.

      John Milton
      (Paradise Lost)

       
  • Deepak

    Deepak - 2014-01-11

    I ran the command "regsvr32 %SystemRoot%\system32\wbem\wbemdisp.dll" and got successfully register output. But, still the above exception.

     
  • Deepak

    Deepak - 2014-01-11

    I have tried multiple things:
    1) Running following sequence of commands for system32 and syswow64
    cd /d %windir%\system32\wbem
    for %i in (.dll) do RegSvr32 -s %i
    for %i in (
    .exe) do %i /RegServer
    2) Connecting to local wmi mgmt by running wmimgmt.msc and clicking on properties. all goes well and I am able to create the instance.

    The following line fails:
    call(Endpoint.IDEMPOTENT, (JIRemoteSCMActivator.RemoteCreateInstance)serverActivation);
    in JIComServer.java line 645

     
  • Deepak

    Deepak - 2014-01-11

    Resolved!. Thanks. Since it is a 64 bit server so I had to do the following:

    a) Open regedit
    b) find key HKey_Classes_Root\Wow6432Node\CLSID{{76A64158-CB41-11D1-8B02-00600806D9B6}} - Added a new REG_SZ (string) Value called AppID with a the COM object GUID as the value.

    c) Added a new key HKey_Classes_Root\Wow6432Node\AppID{{76A64158-CB41-11D1-8B02-00600806D9B6}} - Under this new key, added a new REG_SZ (string) Value called DllSurrogate. Leave the value empty.

     
  • Deepak

    Deepak - 2014-01-15

    Oh!. Customers won't allow to modify their registry. Bump !
    By the way the solution I posted worked on my windows 8 machine but not windows server 2008. But, since customers wont allow modifying their registry I might need to look for alternative solution.

     
    • Vikram Roopchand

      Hi,

      Please try Jacob library, it might help.

      best regards,
      Vikram

      On Wed, Jan 15, 2014 at 12:32 PM, Deepak deepakagarwal@users.sf.net wrote:

      Oh!. Customers won't allow to modify their registry. Bump !
      By the way the solution I posted worked on my windows 8 machine but not
      windows server 2008. But, since customers wont allow modifying their
      registry I might need to look for alternative solution.


      Class not registered. If you are using a DLL/OCX , please make sure it has
      "DllSurrogate" flag sethttps://sourceforge.net/p/j-interop/discussion/840678/thread/8aff0f8c/?limit=25#dccc


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/j-interop/discussion/840678/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

      --
      The Mind is a place of its own. It can make a heaven out of hell or a hell
      out of heaven. Attitude is everything. No matter how adverse conditions
      maybe, one has the capacity to turn things around by one's Determination,
      Perseverance and Hardwork.

      John Milton
      (Paradise Lost)

       
  • Deepak

    Deepak - 2014-01-15

    Great! Jacob worked ! Finished the integration and delivered :)

     

Log in to post a comment.