Help! itracker with mysql 5.6

Help
oam829
2014-02-24
2014-02-25
  • oam829

    oam829 - 2014-02-24

    Hi,

    Could help me know which version is supported by itracker with mysql 5.6?

    I currently have version 3.0.0 but I get errors with this version of mysql.

    11:12:57,135 ERROR [org.hibernate.util.JDBCExceptionReporter] Data truncation: Incorrect datetime value: '' for column 'create_date' at row 1
    11:12:57,147 ERROR [org.itracker.web.actions.admin.project.EditProjectAction] execute: Exception processing form data
    org.springframework.orm.hibernate3.HibernateJdbcException: JDBC exception on Hibernate data access; nested exception is org.hibernate.exception.DataException: could
    not insert: [org.itracker.model.Project]
    Caused by:
    org.hibernate.exception.DataException: could not insert: [org.itracker.model.Project]
    at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:77)
    at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43)
    at org.hibernate.id.insert.AbstractReturningDelegate.performInsert(AbstractReturningDelegate.java:40)
    at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2163)
    at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2643)
    at org.hibernate.action.EntityIdentityInsertAction.execute(EntityIdentityInsertAction.java:51)
    at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:279)

    Regards.

     
  • Marco

    Marco - 2014-02-25

    Hi

    The Hibernate 3.2, which is currently being used by itracker, does not support the 5.6 mySQL server.

    You should consider to either install mysql 5.1 or, if you like to spend some more time, add support to the 5.6 mySQL database.

    Best Regards
    Marco

     
  • oam829

    oam829 - 2014-02-25

    Hi Marco,

    Thank you very much for your help.

    Regards.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks