I have a PXA 270 CPU based board running Linux 2.6.15. I have enabled the IRDA device driver and have got it working. I use the “ irattach ” utility to attach the device irda0. I use the OPENOBEX libraries on top of the IRDA stack/driver to do some file transfer between a PALM and my board. I use the sample irobex_palm3 application and obexftp to get this done. This is how my application flows.


STEP 1. Wait for a file from PALM.

STEP 2. On reception of the file, obexFTP another file to the PALM

STEP 3. Go to STEP 1


I run this in a while(1).


Everything is smooth except for one issue. Most of the times, after the TX of the file via obexFTP it takes nearly 25 seconds before it could actually start receiving my file from PALM again. I get these messages in that time, “IrLAP, no activity on link!

When I tried to debug, this was the major issue,


Nomally the state transitions of LAP are                    XMIT_P --- PCLOSE --- NDM

But in the case when it waits for 25 secs it is             XMIT_P --- NRM_P (Tries with 24 retrans .. causing my delay) --- NDM


Can someone help me how I could reduce this delay.






Maharajan Veerabahu,

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.412 / Virus Database: 268.18.3/693 - Release Date: 2/19/2007