Hello all,
I am working on setting up IrDA communication between omap5910(1510) and my PC. I am using kernel. I got this link from a Samuel Ortiz(many thanx)  on witch I found drivers which should suppose to work on my board.
But I am still unable to make IrDA work on my board. I compiled my kernel with this driver and I ported it to my board.
When I boot up my board and type ifconfig irda0 up in terminal window I got this message.
Irda0  Link encap: UNSPEC Hwaddr ---- and so on.
I tried to compare the result of this command with result that I get when I do the same on my laptop, which is running on Linux and I get something like this.
Irda0 Link encap: IrLAP --- and so on.
So I am little confused about this problem. I trayed to measure signals on my IrDA port with oscilloscope, and I can see that I am receiving some kind of signals but I can not see anything on console.
And one more thing, when I run “echo xxx > /dev/ttyS2” I got constant light on TX port which I can not turn off until I reboot the device.
I am pretty much run off any ideas, so if anyone have any idea please respond J

Want to be your own boss? Learn how on Yahoo! Small Business.