Help save net neutrality! Learn more.
Close

BASE_URL

Help
2005-03-31
2013-05-09
  • Nobody/Anonymous

    Not that it is a problem, but you may want to update the documentation.  I use apache 2.0.53 with IP based virtual hosts.  IPPLAN is in a virtual host with an IP address of X.X.X.X, it does not diplay anything properly when I go to that page.  I then put a / in the define base_url section, this did not work either.  I could not get the page to dispay correctly unitl I put in http://X.X.X.X for the base url even though the comment says not to do it that way. 

     
    • YonksMan

      YonksMan - 2005-04-01

      We also experienced this after we migrated IPplan over to another server that was using a virtual host.

       
      • Richard Ellerbrock

        I have eventually figured this one out! You only have a problem if IPplan is installed in the root directory of the virtual host - for example http://dummy.example.com, not in a subdirectory http://dummy.example.com/ipplan.

        The issue has to do with the way the dirname() function returns a path. Normally a path will be returned as /ipplan - if ipplan is installed in the root dir, / is returned. This creates paths like //menus which freaks out the menu system.

        So patch is in ipplanlib.php, search for base_url() function and add this line:

        if ($tmp == "/") return "";

        after this line:

        $tmp = dirname($_SERVER["PHP_SELF"]);

         
  • Anonymous - 2013-04-18

    Well I just cant get the menus to work properly, I have tried all the options listed in this thread and it will wont work …

    My apache config is pretty simple       

    <VirtualHost XX.XX.XX.XX:443>

    Alias /monitoreoipplan "/usr/share/ipplan"
    ….

    <Directory /usr/share/ipplan>
                    AllowOverride All
                    Options none
                    Order allow,deny
                    Allow from all
            </Directory>

    And thats it….

    In  IPplan´s config.php BASE_URL variable I´ve tried '/'  and  '/monitoreoipplan'

    No dice either way… what am I missing?

     

Log in to post a comment.