Ipod with 1.3 firmware not working

2003-05-03
2003-05-30
  • Justin Davies

    Justin Davies - 2003-05-03

    Hi guys.  I got hold of a second hand ipod on ebay the other day, and I have tested it in OSX and it works, however, in Linux, it will not.  All I can get it to do is know that an Apple device is connected via firewire (and that is only because of the ID).  Trying to get sbp2 to see it as a disk however is a no go.  I have tried everything and I have experience of the ipod under linux as I owned one before.  Does anyone know if Apple has managed to piss us all off and stop the MAc version of the ipod working under Linux ?  BTW, I have tried the ipod under windows, with no avail.

    Justin

     
    • Robert Wittams

      Robert Wittams - 2003-05-15

      Did you load sd_mod?

       
    • Allen T. Gilliland IV

      well ... i have a brand new iPod ... the new model with rev 1.4 and it works fine.

      your ipod probably isn't formatted for windows.  to get it working on linux you need a windows formatted ipod ... so that is the first thing you need to do.  all you should need to do this is to install the MusicMatch software that comes with the ipod and start it up, otherwise there is ephpod which can do it for you as well.

       
    • Nathan Hjelm

      Nathan Hjelm - 2003-05-30

      You dont really need to reformat your ipod to use it under linux anymore. There is a fully-working kernel module which mounts hfsplus disks for read and write.

      As to sbp2 problems... Are you using your ipod under x86 linux? You will need to enable mac partition suport in your kernel to be able to see an ipod with sbp2.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks