ipaudit "refused the connection"

Help
bicado mah
2009-08-26
2013-03-06
  • bicado mah

    bicado mah - 2009-08-26

    Hi everyone,

    I install IPAudit on Debian 5.0.2 on a pc (tread: https://sourceforge.net/forum/forum.php?thread_id=3378240&forum_id=59302 ). With help from JRifkin I enabled the UserDir module and it works.

    Now when I try to install on the second pc, in the same way, I experience the following problem: when I go to http://195.178.xxx.xxx/~ipaudit/ (locally) I get message: "195.178.xxx.xxx refused the connection". But when I go to http://localhost/~ipaudit/ I can see the result.

    When I try to check http://195.178.xxx.xxx/~ipaudit/  from an other pc I get "The connection has timed out".

    I thing is a problem with the permission to read some files but how can I resolv the problem.

    Please help!

    Best regards,
    Bicado

     
    • Jon Rifkin

      Jon Rifkin - 2009-08-26

      Either Apache is not configured to listen on the external network, or you have a firewall blocking HTTP access.

      Try running this
         sudo netstat -ntap | grep apache
      Do you see something like this?
         tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      3503/apache2   
         tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      3503/apache2 
      Notice the 0.0.0.0:80?  That means Apache2 is listening on both the internal (127.0.0.1) and external ( 195.178.x.x) network interface.  If you see this, and cannot reach your server from the network, then you must have a firewall on your network or on your host.

      If instead of 0.0.0.0:80 you see 127.0.0.1:80, then Apache is configured to only listen on the internal interface.  Edit the Apache config files and change
         Listen 127.0.0.1:80
      to
         Listen 0.0.0.0:80
      Similary for 127.0.0.1:443 if it's present.

       
      • bicado mah

        bicado mah - 2009-08-26

        Thanks for the promt answer!

        I do not have installed a firewall on my host (I install Debian and all the needed programs in the same way like for the first pc) and I do not have any firewall on my network.

        When I run "your" command I get:
        tcp6   0    0    :::80    :::*   LISTEN    4835/apache2

        In the ports.conf file I have "LISTEN 80".

        I start to search after if I install by misstake a firewall on the host.

        Many thanks again!

        Best regards,
        Bicado.

         
    • bicado mah

      bicado mah - 2009-08-26

      I find a misstake in the installation of Debian: I have install my network connection with static ip-address but the settings gone lose. I try to set them in the grafic interface for network settings and I lose them every time. Maybe I shell start to make them in command line.

      /Bicado

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks