messed up initial configuration

Help
TommyDIY
2008-01-30
2013-04-19
  • TommyDIY

    TommyDIY - 2008-01-30

    Hi

    Running innotop version 1.6 on Ubuntu

    When I run innotop at command line I get this output.

    test INNODB_STATUS: Can't connect to data source host=localhost, no database driver specified and DBI_DSN env var not set at /usr/local/bin/innotop line 5409

    How do I change the initial configuration settings?

    I also tried to remove innodb completely so I could reinstall a fresh copy but that was unsuccessful too. I deletd all these files & directories

    root@tomtest:~/innotop-1.6.0# find / -name innotop
    /usr/local/bin/innotop
    /usr/local/lib/perl/5.8.8/auto/innotop
    /root/innotop-1.6.0/innotop
    /root/innotop-1.6.0/blib/lib/auto/innotop
    /root/innotop-1.6.0/blib/arch/auto/innotop
    /root/innotop-1.6.0/blib/script/innotop

    and then reran
    tar zxvf innotop-1.6.0.tar.gz

    followed by
    perl Makefile.PL
    make test
    test
    make install

    but when I ran
    innotop
    I get the same error messgae as before.

    Any ides how to fix this or even how to do a clean uninstall?

    Thanks
    Tom

     
    • TommyDIY

      TommyDIY - 2008-01-30

      I have hard coded the correct DSN, user & password into the DBI->connect function in /usr/local/bin/innotop and have acecss now but any info on how to completely uninstall innodb would still be appreciated?

       
      • Anonymous - 2008-01-30

        Completely uninstalling innotop: run the usual make install process, then run make uninstall.  Perl's uninstall doesn't do anything, but it prints out what it would have done.  You can run those commands manually.

        You should not have to hard-code the DSN etc.  You need to set this in your configuration file.  If innotop didn't walk you through these steps the first time you started it, there might be a bug.

        Look in the [connections] section of your innotop config file, in ~/.innotop.  You should see something like the following:

        localhost=user=tommydiy dsn=DBI:mysql:;host=localhost ... [more stuff]

         
    • TommyDIY

      TommyDIY - 2008-01-31

      Thanks for the very prompt reply. I do not think there is a bug, 'user error' was at the heart of the issue here :p I was prompted on initial setup but my selections caused the subsequent failure.

      I am not as exposed to unix as I should be, so I had trouble locating the ~/.innotop directory , the ls command does not show it. I was able to make those changes to the configuration file which in conjunction with the reinstall has me back in action.

      In regard to feedback I echo what others have said about documentation (always the most boring part of any job:p) but your prompt replies in the forum go a good way to making up for any lack of documentation.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks