Won't communicate with my cutter

  • Anonymous - 2010-08-31

    Hi.  I tried InkCut with my US Cutter MH871, but I can't get it to communicate.  I have it plugged into my USB port, and when I try to cut it just ignores me. 
    The Device drop-down does not show anything and is disabled.  If I click Properties, I can set the port and baud rate, but the Test Connection button ignores me when I press it.  Likewise, the Plot Paths button brings up the plot dialog, but doesn't actually do anything except disappear when I press the Send button.  When I close the InkCut dialog, Inkscape presents a dialog that says "Inkscape has received additional data from the script executed.  The script did not return an error, but this may indicate the results will not be as expected." then goes on to say:

    Traceback (most recent call last):
      File "/home/david/.config/inkscape/extensions/inkcut/app/main.py", line 283, in on_send_clicked
      File "/home/david/.config/inkscape/extensions/inkcut/app/bin/device.py", line 98, in plot
      File "/home/david/.config/inkscape/extensions/inkcut/app/bin/device.py", line 75, in toSerial
      File "/home/david/.config/inkscape/extensions/inkcut/app/bin/serial/serialposix.py", line 270, in open
        raise SerialException("Port must be configured before it can be used.")
    app.bin.serial.serialutil.SerialException: Port must be configured before it can be used.

    What am I doing wrong?  This plotter uses the FTDI chip for USB communications, which I've had problems with before. Could that be the cause?

    Thanks, David

  • frmdstryr

    frmdstryr - 2010-09-03

    What port do you have it set to use?  It cannot open a serial connection with your cutter.  The common usb port is /dev/ttyUSB0.  Enter this in the properties if it is not included in the dropdown.

  • Anonymous - 2010-12-03

    i treid inkscape on fedora 14
    send or test button did not work

    i have no permission to /dev/ttyS0
    so no cutting with inkscape
    su chmod 666 /dev/ttyS0     to change permission

    i have send a test file to plotter  from terminal commandline
    set serial port
    stty 19200 cs8 -parenb -parodd  crtscts  -ixon -ixoff  -F /dev/ttyS0
    cat  /hpglfile.plt > /dev/ttyS0

    this whas old db9/25 serial port
    but maybe of some use to tou

    greetings luberth
    inkcut is a nice extension for vinylcutting with linu inkscape
    keep up the good work

  • Hamsiel

    Hamsiel - 2012-01-24

    Regarding port problems:  You must have Your plotter connected on ttyS0 (or one off the first 3 ports )

    My plotter needs: ln -s /dev/ttyACM0 /dev/ttyS0

    Then it comunicates with the plotter.

    BUT i have another issue - the plotter hangs after a short while. If i set up a logger on the ttyS0 - then it slows the speed so much down, that the plotter not hangs.

    If anyone have a solution for this, i would like to hear.

    • lwernars

      lwernars - 2013-11-11

      Perhaps selecting less baud on the plotter and in Inkcut , or select X-on/X-off. Most of the plotters I have worked with, I created printdevices for it, so you let cups do the dirty work with spooling...

  • lwernars

    lwernars - 2013-07-17

    What I do with all my plotters is the same thing:
    - Install a raw printer with the serial/parallel/USB settings just right
    - Set this printer in Inkcut as cutting device

    I believe it will always work, I tested it with a dozen plotters, all different types and brands.
    I have done some really big jobs, more than 10 meters vinyl in one session.
    Just give it a try, especially when you have e serial plotter.
    Inkcut does not always remember the connection-properties for a serial device, is the result from my tests.
    At this moment I have a Summa D-120 S, of course cutting with Inkcut.
    Plotters I have had:
    - HP penplotters A4 & A3
    - Roland Stika SX-8
    - Roland Camm-1: 5 different types :PC60, CX-24, CM-24, and some older ones.
    - GCC: Puma III, Puma II-132, Bobcat
    - Helo HSP-720
    - Roland Stika SX12
    Quite a list in just one year....

    I had issues with DMPL-plotters, but I can cut with them from Inkcut. Modified the HPGL to a few versions DMPL, so that is also good!

    Last edit: lwernars 2013-10-28
  • gnaural

    gnaural - 2014-07-12

    Great tip, lwernars. Thank you. I have a new Silhouete Cameo, and have gotten it to cut in Ubuntu using a variation of Robocut as tweaked here:

    But that's not a big-picture solution, since it gives virtually no control. Inkcut certainly looks amazing, and the "long term solution", but so far I can't get it to communicate with my the Cameo. I've installed it as a RAW printer in CUPS, but "test connection" gives me the dmesg info:

    [ 5037.900291] type=1400 audit(1405167823.151:83): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=3580 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"
    [ 5045.031656] type=1400 audit(1405167830.287:84): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=3580 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"
    [ 5045.031662] type=1400 audit(1405167830.287:85): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=3580 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"
    [ 5045.031666] type=1400 audit(1405167830.287:86): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=3580 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"

    Any tips? Looks like a permissions thing, but I'm already a memember of every user group I know of. Maybe there is one I don't know of :-)

    IF it helps, when i plug-in the Cameo, dmesg gives me:

    [ 4568.033900] usb 3-1: new full-speed USB device number 7 using xhci_hcd
    [ 4568.057039] usb 3-1: New USB device found, idVendor=0b4d, idProduct=1121
    [ 4568.057049] usb 3-1: New USB device strings: Mfr=0, Product=0, SerialNumber=1
    [ 4568.059420] usblp 3-1:1.0: usblp1: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x0B4D pid 0x1121

    Sorry if this isn't offering the salient info, or is otherwise incomplete, I am brand new to the area of cutting machines. That said, I am a long-term linux and Inkscape user, if that helps.

    Btw, I saw your other excellent post dealing with the Cameo here:

    So I will be expecting the GP-GL/HPGL issues, and am not too worried about that now. Just getting the machine and Inkcut to speak are my priority. Thanks

  • gnaural

    gnaural - 2014-07-12

    OK, update (sending asap simply you don't waste time with stuff i've already solved) - I am able to get it to communicate now, I can test connection fine, and i can send a print job to it, albeit with no blade on for the moment (solving the GP-GL/HPGL translation will come next). The issue now appears to be scaling/calibration and orientation. First try it litterally dropped the mat on the floor by misjudging the height; second try, with Calibration set to 0.5, it seems to stay within borders fine, it simply is oriented wrong. I think i can figure orientation out eventually, but any tips on how to do scaling without fudge-factoring it? Like, a dpi setting somewhere? And as for the next task - solving GP-GL/HPGL translation - is the best approach for now literally to do a search-replace on the print string before it goes out? Thanks!

  • lwernars

    lwernars - 2014-10-21

    Is your Cameo on this port: /dev/usb/lp1 ??
    But now I see you have a connection, that is good.

    Inkcut has 1016 points in one inch, that is somewhere in the code. I believe in main.py.
    You can change the y-axis, but for some plotters the output is then horrible.

    HPGL/GP-GL translation can be done with a few search/replace commands. I have done that for the DMPL-translations.


Log in to post a comment.