|
From: Tobias G. <gut...@fz...> - 2003-04-30 12:44:05
|
Hi all!
As planned, named model elements should implement the interface
NamedModelElement, which
declares the two methods getName() and getShortName().
However, in Recoder, the interface ProgramModelElement declares the two
methods getName() and getFullName(), where getName() would be our
getShortName(), and getFullName() our getName().
I think it might become a little confusing looking at some source code
like this:
public String getName() {
return myElement.getFullName();
}
public String getShortName() {
return myElement.getName();
}
What do you think about following the naming of recoder?
bye
Tobias
|