Recording performance

Help
JReykdal
2013-01-17
2013-04-25
  • JReykdal

    JReykdal - 2013-01-17

    OS: Suse 11.4

    Hardware:
    HP ML150 G6
    1x Xeon 5504 @2000MHz (4 core, no HT)
    RAM 10GB
    system on SSD
    /video on RAID-0 (hdparm -tT gives about 180MB/s)
    Atomix LT card with latest driver and firmware

    Is this system too slow to record 2 HD streams at the same time? I've tried both DVCPro-HD and dnxhd with no success.

    command line:

     sudo nice --10 ./dvs_sdi -c 2 -mode 1920x1080i25 -f YUV422 -s None -mc 0 -tt SYS 
    /code]
    I put the secondary buffer to None. Was that wrong? 
    I've tried to increase shmmax to 2048 and put -m 2048 to the command line.
    Recorder processes run up to 200% in top (cpu hovering around 99%)
    Soon after starting the recording I start to get:
    [code14:21:04.578 input1 index 0 EncodeFrameBuffer contains 250 frames (1 coded)
    ]
    

    and then:

    MtEncoder missed frame   2593!
    14:21:04.872 input1 index 0 EncodeFrameBuffer contains 253 frames (4 coded)
    input1 index 0 Coded frame 2593 has error!
    14:21:04.897 input1 index 0 EncodeFrameBuffer contains 252 frames (2 coded)
    

    And finally it segfaults.

    I've tried running it headless from the command line to exclude X but that seems to have no effect.

    Regards,

    JR

     
  • John Fletcher

    John Fletcher - 2013-01-17

    Yes, maybe too slow.  DVCPRO-HD is a lot easier to code than DNxHD.  Did you try just one channel of video?  You can see individual core usage with gkrellm - check whether they are peaking to full scale.

     
  • JReykdal

    JReykdal - 2013-01-17

    One channel seems to work fine.

    Now has it been recording for 30 minutes or so with each core around 75%. When I started I was using a terrible upscaled signal from a bad source. Maybe that also is working against it.

    Guess this is what happens when you're not a part of the buying process :D

    JR

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks