QuickTime broken?

  • JReykdal

    JReykdal - 2012-07-03

    I'm having problems recording in QuickTime (DV25 and DV50).
    Files are being created outside the "Creating" folder and resulting files are unplayable with ffmpeg -i telling me that it's just an .wav file?

    ingex@mc-ingex1:/video/dv/kosningavokur> file 20120630_16520909_kosningavokur_mc-ingex1-b_input1_0.mov
    20120630_16520909_kosningavokur_mc-ingex1-b_input1_0.mov: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 48000 Hz

    I'ts happening on 2 different machines. One an older (pre bmx cvs) install and one from last week with BMX.

    IMX30 .mxf is working fine and also working in HD (XDCAM QT).



  • John Fletcher

    John Fletcher - 2012-07-04

    Yes, it seems to be broken.  Will look into fixing it.

  • John Fletcher

    John Fletcher - 2012-07-04

    Should be fixed now.

  • JReykdal

    JReykdal - 2012-07-04

    Works now.

    Thank you.


  • Ivan

    Ivan - 2012-07-05

    Another thank you!
    Just one more, :) now I must connect to cvs and run:
    "cvs -z3 update -Pd" then
    "make clean" and
    to update installation, right?

  • John Fletcher

    John Fletcher - 2012-07-06

    Correct.  The "make clean" may not be needed but it is often a good idea.

    You may need to update the libMXF, libMXF++ and bmx libraries first:

    > cd libMXF
    > git pull
    > make && sudo make install

  • Ivan

    Ivan - 2012-07-10

    Hi John, me again (sorry:)
    I've updated libMXF, libMXF++ and bmx but when I execute >cvs -z3 update -Pd
    I get CVSROOT variabile error, so I suppose that I need to specify CVSROOT in ~/.bashrc
    So the question is:
    Is CVSROOT "$workspace/ingex" or "cvs -z3 -d:pserver:anonimous@ingex.cvs.sourceforge.net:/cvsroot/ingex co -P ingex"
    :) yes I'm beginner

  • John Fletcher

    John Fletcher - 2012-07-10

    If you're in the directory where you previously checked out the Ingex code, you shouldn't need to specify cvsroot.
    Do you have an environment variable CVSROOT set that conflicts with what you previously used?
    The cvsroot should be :pserver:anonymous@ingex.cvs.sourceforge.net:/cvsroot/ingex and you can specify it with -d option on the cvs command line.

  • Ivan

    Ivan - 2012-07-10

    I think I was in $workspace > /ap-workspace/ingex, at least I think I was, but probably I was wrong..  Anyway, just restored entire disk from backup and… Will try again.. :)  And I didn't set any variable for CVSROOT.


  • Matthew Marks

    Matthew Marks - 2012-07-10

    In any of the Ingex directories you will find a subdirectory called CVS.  That contains files used by CVS to manage the files in the parent directory, including "Root", which tells CVS where to find the repository - hence what John says about not needing to specify one.  If you happen to have a CVSROOT environment variable (not necessarily set by you: try

    env | grep CVSROOT

    it will override the one in the file.

  • Ivan

    Ivan - 2012-07-16

    Yes, I was wrong. I just didn't cd to $workspace :) everything work and updated but QT still doesn't work.. It starts to record but after couple of seconds (sometimes 5, sometimes 10-15) recorder just stop working.. I'll try with debug and I'll post messages..


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks