SourceForge has been redesigned. Learn more.

NoClassDefFoundError - LogFactory

  • psililisp

    psililisp - 2006-01-09

    I was first able to use Informa bundled in a stand-alone Java application run from the command line, and everything worked fine.

    However, I ported my application to be used as a Tomcat servlet in a webapp container, and since then, I get this error message when trying to run it:

    java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
    at de.nava.informa.impl.basic.ChannelBuilder

    I have tried using just commons-logging.jar as well as commons-logging.jar and log4j-1.2.8.jar in my WEB-INF/lib/ directory and I can't get around this error. I've looked over the production
    Tomcat install and can find no conflicts with those jars being anywhere else.

    Any ideas on where I could look, or what I could be missing would be stellar.

    And thanks for this parser by-the-way. It worked great in the stand-alone app.

    • psililisp

      psililisp - 2006-01-09

      Additionally, the error occurs on line:61 in, where

      private static Log logger = LogFactory.getLog(ChannelBuilder.class);

      is declared.

      For debugging this, I added a LogFactory to part of my servlet that's executed before I call ChannelBuilder and it runs just fine and I can see the logging.

      Anyway, thanks anyone for some input and have a great day.


Log in to post a comment.