Bill Clementson wrote:

Looks like ilisp isn't finding the clisp.bat batch file. Did you put it in
the recommended location (c:\home\lisp)? If so, have you prepended
c:\home\lisp to your path as indicated in step#8? Check your PATH again just
to make sure.

If everything else is ok, try editing your clisp.bat file so that it looks
like the following:

@echo off
"D:\Program Files\clisp-2.28\lisp.exe" -B "D:/Program Files/clisp-2.28/" -M
"D:/Program Files/clisp-2.28/lispinit.mem" %1 %2 %3 %4 %5 %6 %7 %8 %9

Note that I've only changed the "/" to "\" in the lisp.exe path, not the
paths of the parameters. IIRC, winnt & win2000 don't care about "/" but
win98 sometimes has problems with them.

Hope that helps. Let us know what worked or if you are still having
problems.

Thanks much.  This appears to have improved things, but I am still getting an error.  I changed my autoexec.bat file and moved "C:\home\lisp" in front of "C:\emacs-21.1\bin" though I don't see that this would make any difference.  I also changed my clisp.bat file as suggested.  Here is what I get now:

Split screen display with Dired at top and clisp at botton.  Modelines as follows:

Top:   -1\%%  home                      (Dired by name)--L14--C0--All----------------------------------------- 

Bot:  -1\**  *clisp-hs*                    (ILISP :exit)--L4--C0--Top----------------------------------------------

Here is what appears in the bottom half of the split screen instead of the error that I was getting before:

Starting clisp -ansi -I -q ...
ILISP V5.11.1  Use M-x ilisp-bug for problems and suggestions.
GNU CLISP (http://clisp.cons.org/) is an ANSI Common Lisp.^M
Usage:  D:\PROGRA~1\CLISP-2.28\LISP.EXE [options] [lispfile [argument ...]]^M
 When `lispfile' is given, it is loaded and `*ARGS*' is set^M
 to the list of argument strings. Otherwise, an interactive^M
 read-eval-print loop is entered.^M
Informative output:^M
 -h, --help    - print this help and exit^M
 --version     - print the version information^M
 --license     - print the licensing information^M
Memory image selection:^M
 -B lisplibdir - set the installation directory^M
 -M memfile    - use this memory image^M
 -m size       - memory size (size = xxxxxxxB or xxxxKB or xMB)^M
Internationalization:^M
 -L language   - set user language^M
 -N nlsdir     - NLS catalog directory^M
 -Edomain encoding - set encoding^M
Interoperability:^M
 -q, --quiet, --silent - do not print the banner^M
 -w            - wait for keypress after program termination^M
 -I            - be ILISP-friendly^M
Startup actions:^M
 -ansi         - more ANSI CL compliance^M
 -traditional  - traditional (undoes -ansi)^M
 -p package    - start in the package^M
 -C            - set *LOAD-COMPILING* to T^M
 -norc         - do not load the user ~/.clisprc file^M
 -i file       - load initfile (can be repeated)^M
Actions:^M
 -c [-l] lispfile [-o outputfile] - compile LISPFILE^M
 -x expression - execute the expression, then exit^M
 lispfile [argument ...] - load lispfile, then exit^M
Default action is an interactive read-eval-print loop.^M
Bad command or file name^M
 
If I ignore this error and press on with " use "M-x ilisp-compile-ints" " I get the same error as before, i.e.
 
Wrong type argument:  processp, nil
 
Looks like progress made with suggested changes, but still no cigar.
 
Regards,
Jeff Stephens