Error 403

  • Superman1001

    Superman1001 - 2010-02-14

    I got windows vista with apache installed, when i try to access at i got the 403 error!

    Forbidden You don't have permission to access /fcgi-bin/IIPImageServer.fcgi
    on this server. - - [14/Feb/2010:20:40:55 +0100] "GET /fcgi-bin/IIPImageServer.fcgi HTTP/1.1" 403 230

    how to fix it?

  • Ruven

    Ruven - 2010-02-15

    Take a look in the Apache log file. The problem is either that you have not
    properly installed the Apache fcgi module or that you have not configured it
    to use IIPImage.

  • Superman1001

    Superman1001 - 2010-02-15

    this is the httpd.conf:

    LoadModule fcgid_module modules/
    <IfModule fcgid_module>
    # IIPImageServer configuration directory
    Include conf/extra/httpd-iipimage.conf

    and this is the httpd-iipimage.conf:

    # Settings for user home directories
    # Required module: mod_fcgid
    # Create a directory for the iipsrv binary
    ScriptAlias /fcgi-bin/ "C:/Program Files/Apache Software Foundation/Apache2.2/fcgi-bin"
    # Set the options on that directory
    <Directory "C:/Program Files/Apache Software Foundation/Apache2.2/fcgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    # Set the module handler
    AddHandler fcgid-script .fcgi
    # Set our environment variables for the IIP server
    DefaultInitEnv VERBOSITY "0"
    DefaultInitEnv LOGFILE "C:/Program Files/Apache Software Foundation/Apache2.2/logs/IIPImageServer.log"
    DefaultInitEnv MAX_IMAGE_CACHE_SIZE "10"
    DefaultInitEnv JPEG_QUALITY "50"
    DefaultInitEnv MAX_CVT "3000"
    # Define the idle timeout as unlimited and the number of processes we want
    IdleTimeout -1
  • Ruven

    Ruven - 2010-02-18

    Are you trying the test image from the the IIPImage site? Where did you put
    it? Does Apache have read access to the image? Have you set the java, flash,
    javascript etc image paths to correctly point to this image? Try also
    following some of the steps from the troubleshooting page on the site.

  • Superman1001

    Superman1001 - 2010-02-21

    i solved it! it was a wrong format if tiff images
    but the first problem is not yet solved

  • Ruven

    Ruven - 2010-02-21

    Excellent! But what is the remaining problem?

  • Superman1001

    Superman1001 - 2010-02-21

    for now the fcgi-bin folder is locate in c:\www\, if i put it into
    C:\Programs\Apache Software Foundation\Apache2.2\, i got error 403



Cancel  Add attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks