_pyr_ suffix

Help
lauriesk
2008-01-29
2014-12-19
  • lauriesk

    lauriesk - 2008-01-29

    Hi,

    output from iipsrv.log:
    --------------------//--------------------
    CVT maximum viewport size set to 3000
    Full Request is FIF=tif/PalaisDuLouvre.tif&obj=IIP,1.0&obj=Max-size&obj=Tile-size&obj=Resolution-number
    [1/5]: Command / Argument is FIF : tif/PalaisDuLouvre.tif
    FIF handler reached
    tif/PalaisDuLouvre.tif_pyr_ is neither a file or part of an image sequence


    Content-type: application/vnd.netfpx
    Content-disposition: inline;filename="IIPisAMadGameClosedToOurUnderstanding.netfpx"

    Error/7:1 3 FIF


    Total Request Time: 322 microseconds
    image closed and deleted
    Server count is 1
    --------------------//--------------------

    It seems pyr suffix is added automaticaly. PalaisDuLouvre.tif is example image from IIPInafe website. What am I doing wrong?

     
    • Ruven

      Ruven - 2008-01-29

      Try using the full path to the image in your FIF parameter instead of just "tif/PalaisDuLouvre.tif". Don't forget that the iipsrv server instance is run as the same user and with the same permissions of the web server, so any relative path must be with respect to this. Thus, it's always best to simply use the full path. (The suffix thing is only added if it cannot find the image, in which case it attempts to find a sequence of images instead of just a single TIFF.)

       
    • lauriesk

      lauriesk - 2008-01-29

      Found solution: wrong image location.
      (note to self: before posting to forums also look into threads named 'Windows ....')

       
  • Anonymous - 2014-12-19

    Hi ,
    I am having the same problem using the testing image PalaisDuLouvre.tif but nothing seems to work. I set up local env using Vagrant and I've tried as var images almost everything possible (PalaisDuLouvre.tif , /PalaisDuLouvre.tif, http://192.168.56.101/iip/PalaisDuLouvre.tif, 192.168.56.101/iip/PalaisDuLouvre.tif) but nothing seems to work.

    When I check the log files I only get:

    CVT maximum viewport size set to 5000
    QUERY_STRING not set

    Total Request Time: 87 microseconds
    image closed and deleted
    Server count is 6

    CVT maximum viewport size set to 5000
    Full Request is FIF=http://192.168.56.101/iip/PalaisDuLouvre.tif&obj=IIP,1.0&obj=Max-size&obj=Tile-size&obj=Resolution-number
    [1/5]: Command / Argument is FIF : http://192.168.56.101/iip/PalaisDuLouvre.tif
    FIF handler reached
    FIF :: URL decoding/filtering: http://192.168.56.101/iip/PalaisDuLouvre.tif => http://192.168.56.101/iip/PalaisDuLouvre.tif
    FIF :: Image cache initialisation
    http://192.168.56.101/iip/PalaisDuLouvre.tif is neither a file or part of an image sequence


    Server: iipsrv/0.9.9^M
    Cache-Control: no-cache^M
    Content-Type: application/vnd.netfpx^M
    Content-Disposition: inline;filename="IIPisAMadGameClosedToOurUnderstanding.netfpx"^M
    ^M
    Error/7:1 3 FIF^M


    Total Request Time: 322 microseconds
    image closed and deleted
    Server count is 7

    Could you please help me with this that it getting me crazy.

    Kind regards,
    Eduardo

     
  • Ruven

    Ruven - 2014-12-19

    You are passing a URL to iipsrv and not the image path. Where exactly is your image located? If you give the correct path and it still doesn't work, make sure your web server has permission to read the image. The troubleshooting guide may also help.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks