• Anonymous

    I am trying to get the server running just to test some images I am creating using VIPS.

    I have server installed using this guide: http://iipimage.sourceforge.net/2012/10/iipimage-now-an-official-ubuntu-package/

    Although the server is not starting. There is no log created in /var/logs/. When I go to ’http://localhost/iipsrv/iipsrv.fcgi’ I am getting 403 error. Tried changing the access rights for the /usr/lib/iipimage-server/ but that made no difference. When trying to access using the example iipmooviewer.html I am getting ‘No response from server http://localhost/iipsrv/iipsrv.fcgi’. Also tried setting server to just ‘iipsrv/iipserv.fcgi’ but that made no difference ( no ‘no response’ message either, just black screen). All the above happen while working locally. Have I missed something ? Or are there compatibility issues with 14.04 ?


    • Anonymous

      I had to create a file log at /var/log/iipsrv.log and then ensure the www-data user has write access,

  • Ruven

    It should just work if you install using the package manager or apt-get:

    apt-get install iipimage-server

    Did you restart Apache after? Then navigating to http://localhost/iipsrv/iipsrv.fcgi should give you the iipsrv info page

  • latusaki

    Hello Ruven, Yes I did restart apache. Since it didn't work, I tried changing various options in the config files that affected access rights but that made no difference. Other than apache, is there anything else that needs to be installed before getting the server through apt-get?

  • Ruven

    I've installed a fresh Ubuntu 14.04 and it looks like the problem is related to the new Apache 2.4 authorization syntax. The access_compat module is enabled by default, so this shouldn't be a problem, but for some reason, the default settings in apache2.conf are not overridden by iipsrv.conf. So the solution I found so far is to change denied to allowed in apache2.conf:

    <Directory />
    Require all allowed

    If anyone has a better solution, please let me know!

  • Markus Barth
    Markus Barth

    ScriptAlias /fcgi-bin /var/path/to/iipsrv
    <Directory /var/path/to/iipsrv>
        Require all granted
    #Initialise the FCGI server - set some default values
    FastCgiServer /var/path/to/iipsrv/iipsrv.fcgi \
    -idle-timeout 100 \
    -initial-env LOGFILE=/var/log/iipsrv.log \
    -initial-env VERBOSITY=0 \
    -initial-env JPEG_QUALITY=80 \
    -initial-env MAX_IMAGE_CACHE_SIZE=0 \
    -initial-env MAX_CVT=5000 \
    -initial-env MEMCACHED_SERVERS=localhost \
    -initial-env MEMCACHED_PREFIX=normal

    is working for me.



Cancel   Add attachments