Must be root user for ifpgui (Device is busy)

Help
2005-12-28
2013-04-17
  • Nobody/Anonymous

    I have the same problem as another person mentioned on this forum. I am using ifpgui 0.10.6 on a Suse 10. My device is a iRiver ifp-300T. I am only able to use the software as root. When I am a non-root user I always get the message "Device is busy". I did execute the nonroot.sh script which created a ifp group. I manually added my nonroot user to this group, yet the problem is still there. Did I miss something ? Am I doing soemthing wrong ? Thanks for any help

     
    • Jim Campbell

      Jim Campbell - 2005-12-28

      Typically, SuSE works out-of-the box.  There is still uncertainty regarding the access.  Several users are unable to access their device unless they are root.  Here are some things to try.
      1) remove the file /etc/hotplug/usb/ifpdev
          remove the all the ifpdev entries from the file /etc/hotplug/usb.usermap
             if the file /etc/hotplug/usb.usermap is empty after you remove all the ifpdev
             entries then just delete the file /etc/hotplug/usb.usermap.

      2) make sure the file /etc/resmgr.conf contains:
             # for libusb access
              class usb
      And
             class desktop includes usb

      3) disable SE Linux if it is enabled (I'm not exactly sure how to do this).

      Thanks
      Jim

       
    • Jim Campbell

      Jim Campbell - 2006-05-05

      I think I have found the fix for the problem where you cannot access the
      ifp-device unless you are the root user.  Here is what I have found to
      work on my system.

      Edit the file
      /etc/udev/rules.d/50-udev.rules

      I had to add the the OWNER, GROUP, MODE, and OPTIONS to the
      SUBSYSTEM="usb_device" section.
      I did not experiment with it, but this could be a start for those that
      are having problems.

      <snip>
      # libusb device access (mount usbfs or usbdev nodes)
      DEVPATH=="/module/usbcore", ACTION=="add", RUN+="/bin/mount -t usbfs
      usbfs /proc
      /bus/usb", GROUP="users", MODE="0766"
      SUBSYSTEM="usb_device", PROGRAM="/bin/sh -c 'X=%k X=$${X#usbdev}
      B=$${X%%%%.*} D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c",
      OWNER="root", GROUP="users", MODE="0766", OPTIONS="last_rule"
      <snip>

      Thanks
      Jim

       
    • Nobody/Anonymous

      I was really happy to see your post Jim. Unfortunately, your solution did not work for me. I also am a Suse 10 user with this exact problem. I am using the latest version of ifpgui (although previous versions have given me the same problem).  I fallowed the instructions to the letter but the "Device is busy cannot claim its interface" problem persists. I still could only run the application as root.

      Walter

       
      • Jim Campbell

        Jim Campbell - 2006-05-24

        I should have posted a follow-up.  After my initial excitement, I found that this worked but it messed up all my usb printers.  Therefor, it really did not work.  So I'm back to the drawing board.  I think I installed something or updated a package and that is when I could not access my device unless as root.  I believe this because it works on a fresh install of SuSE 10.0 and 10.1.

        Sorry for the false hope.

        Jim

         
    • Nobody/Anonymous

      On my PC I have fixed the problem of using ifpgui as a normal user especially under OpenSuse 10.2 for the iRiver IFP 890. I think it works fine with other modells of the company.

      In the directory "/etc/udev/rules.d" I create a file with the name:
        66-ifgui.rules
      and the contents of:
      KERNEL=="usb", DEVICE=="USB", SYSFS{idVendor}=="4102", GROUP="users"

      You can modify the group or the vendor if necessary.

      regards
      Uwe

       
      • Jim Campbell

        Jim Campbell - 2007-02-06

        Thanks Uwe.
          If anyone can verify that this works please let us know.  I cannot verify this because my current system (OpenSUSE 10.1) works just fine and I don't want to experiment ;)

         
    • Nobody/Anonymous

      This doesn't work for me.  I changed the group value to a group to which I belong.  Also, when the device is plugged in the idVendor for the port it is on ==4102. 

      This is what I see on the commandline when I run as a user:

      dberg@ubuntu:~/Desktop$ ifpgui
      libifp.so: cannot open shared object file: No such file or directory
      Device is busy.  (I was unable to claim its interface.)

      The libifp.so... line is there when running as root as well.

      This is on an Ubuntu Edgy install.

      Any thoughts?

      --Dave

       
    • Nobody/Anonymous

      Here is a fix for ubuntu users:

      as root, edit the file /etc/udev/rules.d

      Find the lines:
      # USB devices (usbfs replacement)
      SUBSYSTEM=="usb_device",    

      then insert these three lines after it:
      # iRiver music players
      SUBSYSTEM=="usb_device", GROUP="plugdev", \ SYSFS{idVendor}=="4102", SYSFS{idProduct}=="10[01][135789]"

      save the file. Then restart udev by running:

      $ sudo /etc/init.d/udev restart

      This is reported as a bug in ubuntu.  https://bugs.launchpad.net/ubuntu/+source/libifp/+bug/48871

      --Dave

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks