idjc jack and skype

  • usually

    usually - 2013-04-16

    i follow this guide but for my system doesn't work, infact when I launch idjc and I connect with skype there is no option to change the default pulse audio server in Skype and there is no audio in all the system apart in idjc.
    I paste my .asoundrc

    pcm.pulse {
        type pulse
    ctl.pulse {
        type pulse
    pcm.!default {
        type pulse
    ctl.!default {
        type pulse
    # VoIP plugin for the IDJC default profile.
    pcm.idjcvoip {
       type plug
       slave.pcm {
          type jack
          playback_ports {
             0 idjc_default:voip_in_l
             1 idjc_default:voip_in_r
          capture_ports {
             0 idjc_default:voip_out_l
             1 idjc_default:voip_out_r

    my workaround to solve this problem is to modify the post startup script in Qjacktl  adding this string "pactl load-module module-jack-sink channels=2; pactl load-module module-jack-source channels=2;pacmd set-default-sink jack_out".
    Then i launch first of all Qjackctl and then IDJC, in this way i can connect Pulse audio with JACK with Qjackctl

    But there is an option to connect only skype to jack?

    I''ve linux mint 14.1 64bit

  • Stephen Fairchild

    If you want the alsa options in Skype you have to uninstall pulseaudio. I can understand why you might not want to do this.

  • usually

    usually - 2013-05-04

    ah ok, ok I think that sooner or later i will uninstall pulseaudio :)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks