NoSuchElementException when creating project

Help
2008-02-11
2013-04-09
  • Benoit Maisonny

    Benoit Maisonny - 2008-02-11

    Hi,

    I get the following exception stack trace when doing Projects -> Open Project and then selecting a file, in order to create a new project. Might help or not: the project menu has several empty items under 'Quit'.

    I tried with various JVM (1.5 and 1.6).

    Cheers,
    Benoit

    Exception in thread "AWT-EventQueue-0" java.util.NoSuchElementException
            at java.util.StringTokenizer.nextToken(Unknown Source)
            at biz.chitec.quarterback.util.LocaleConverter.stringToLocale(LocaleConverter.java:30)
            at net.sourceforge.i18nedit.Project.loadProject(Project.java:379)
            at net.sourceforge.i18nedit.I18NEdit.openProject(I18NEdit.java:358)
            at net.sourceforge.i18nedit.I18NEdit.openProject(I18NEdit.java:387)
            at net.sourceforge.i18nedit.I18NEdit$7.actionPerformed(I18NEdit.java:131)
            at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
            at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
            at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
            at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
            at javax.swing.AbstractButton.doClick(Unknown Source)
            at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
            at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
            at java.awt.Component.processMouseEvent(Unknown Source)
            at javax.swing.JComponent.processMouseEvent(Unknown Source)
            at java.awt.Component.processEvent(Unknown Source)
            at java.awt.Container.processEvent(Unknown Source)
            at java.awt.Component.dispatchEventImpl(Unknown Source)
            at java.awt.Container.dispatchEventImpl(Unknown Source)
            at java.awt.Component.dispatchEvent(Unknown Source)
            at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
            at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
            at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
            at java.awt.Container.dispatchEventImpl(Unknown Source)
            at java.awt.Window.dispatchEventImpl(Unknown Source)
            at java.awt.Component.dispatchEvent(Unknown Source)
            at java.awt.EventQueue.dispatchEvent(Unknown Source)
            at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
            at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
            at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
            at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
            at java.awt.EventDispatchThread.run(Unknown Source)

     
    • Jaime Hyland

      Jaime Hyland - 2008-10-28

      I'm afraid I'm only replying to this message to say that I'm having precisely the same problem.

      I'll come back to you when and if I find a solution.

       
    • Jaime Hyland

      Jaime Hyland - 2008-10-28

      By the way: I'm using jdk1.5.0_15 working under UBUNTU 8.04 on a VMWare-Workstation 6.0.2.

       
    • Jaime Hyland

      Jaime Hyland - 2008-11-02

      I have found a solution to this problem on this very site:

      https://sourceforge.net/tracker/index.php?func=detail&aid=2012645&group_id=57658&atid=484945

      It worked for me like a dream.

      Check it out.

      Best of luck.

      JaimeHy

       
    • Stefan Krüger

      Stefan Krüger - 2009-07-30

      I have exactly the same problem. Running
      java version "1.6.0_14"
      on Ubuntu 09.04

      Any ideas?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks