doesn't seem to be too much in the way of user interaction with this project...

I am trying to install on 2.6.14-1.1644_FC4  - have followed all posted instructions on website and get the following error on install

./configure --prefix=/usr --disable-v4l2

make[2]: Entering directory `/usr/src/devsec-3.0.6/ffmpeg'
make -C libavcodec all
make[3]: Entering directory `/usr/src/devsec-3.0.6/ffmpeg/libavcodec'
gcc -O3 -g -Wall  -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -msse -c -o common.o common.c
In file included from avcodec.h:14,
                 from common.c:28:
common.h:67: error: array type has incomplete element type
common.h:71: error: array type has incomplete element type
make[3]: *** [common.o] Error 1
make[3]: Leaving directory `/usr/src/devsec-3.0.6/ffmpeg/libavcodec'
make[2]: *** [lib] Error 2
make[2]: Leaving directory `/usr/src/devsec-3.0.6/ffmpeg'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/devsec-3.0.6'
make: *** [all] Error 2

Can't quite understand how to apply patch file (maybe I'm stupid)..please provide some clearer instructions.  Product looks nice, but if I can't install is useless..