I have a problem with htdig installation on FC5. I have downloaded htdig-3.1.6.
 
Running ./configure
 
Start as if all will go well but finally it displays:
 
configure: error: To compile ht://Dig, you will need a C++ library. Try installing libstdc++.
 
I then decided to install libstdc++ with:
 
yum install libstdc++
 
Which did not complain until it finished.
 
I then run ./configure again but the same error
configure: error: To compile ht://Dig, you will need a C++ library. Try installing libstdc++.
 
I decided to download libstdc++-2.8.0.tar.gz from
 
ftp://ftp.gnu.org/gnu/libstdc++/
 
Having downloaded and unpacked it I proceeded as follows:
 
]#./configure
Configuring for a i686-pc-linux-gnu host.
Created "Makefile" in /home/hosea/downloads/libstdc++/libstdc++-2.8.0 using "mt-frag"
 
]# make
 
This gave some errors error towards the end as follows:
 
gcc -c -g -O2 -I. -I./../include  choose-temp.c
choose-temp.c: In function ‚choose_temp_base‚:
choose-temp.c:127: warning: incompatible implicit declaration of built-in function ‚strlen‚
choose-temp.c:130: warning: incompatible implicit declaration of built-in function ‚strcpy‚
choose-temp.c:145: warning: incompatible implicit declaration of built-in function ‚abort‚
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   concat.c -o pic/concat.o
gcc -c -g -O2 -I. -I./../include  concat.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   cplus-dem.c -o pic/cplus-dem.o
gcc -c -g -O2 -I. -I./../include  cplus-dem.c
cplus-dem.c: In function ‚demangle_template‚:
cplus-dem.c:1075: warning: incompatible implicit declaration of built-in function ‚abort‚
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   fdmatch.c -o pic/fdmatch.o
gcc -c -g -O2 -I. -I./../include  fdmatch.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   fnmatch.c -o pic/fnmatch.o
gcc -c -g -O2 -I. -I./../include  fnmatch.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   getopt.c -o pic/getopt.o
gcc -c -g -O2 -I. -I./../include  getopt.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   getopt1.c -o pic/getopt1.o
gcc -c -g -O2 -I. -I./../include  getopt1.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   getruntime.c -o pic/getruntime.o
gcc -c -g -O2 -I. -I./../include  getruntime.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   hex.c -o pic/hex.o
gcc -c -g -O2 -I. -I./../include  hex.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   floatformat.c -o pic/floatformat.o
gcc -c -g -O2 -I. -I./../include  floatformat.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   objalloc.c -o pic/objalloc.o
gcc -c -g -O2 -I. -I./../include  objalloc.c
objalloc.c: In function ‚objalloc_free_block‚:
objalloc.c:214: warning: incompatible implicit declaration of built-in function ‚abort‚
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   obstack.c -o pic/obstack.o
gcc -c -g -O2 -I. -I./../include  obstack.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   pexecute.c -o pic/pexecute.o
gcc -c -g -O2 -I. -I./../include  pexecute.c
pexecute.c: In function ‚pexecute‚:
pexecute.c:596: warning: incompatible implicit declaration of built-in function ‚exit‚
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   spaces.c -o pic/spaces.o
gcc -c -g -O2 -I. -I./../include  spaces.c
test -z "" || \
  gcc -c -g -O2 -I. -I./../include   strerror.c -o pic/strerror.o
gcc -c -g -O2 -I. -I./../include  strerror.c
strerror.c:460: error: static declaration of ‚sys_nerr‚ follows non-static declaration
/usr/include/bits/sys_errlist.h:27: error: previous declaration of ‚sys_nerr‚ was here
strerror.c:461: error: conflicting types for ‚sys_errlist‚
/usr/include/bits/sys_errlist.h:28: error: previous declaration of ‚sys_errlist‚ was here
make[1]: *** [strerror.o] Error 1
make[1]: Leaving directory `/home/hosea/downloads/libstdc++/libstdc++-2.8.0/libiberty'
make: *** [all-libiberty] Error 2
 
So I cannot proceed installing htdig.
 
Any advise.
 
Hosea
 
 
 
 
 
 


Finding fabulous fares is fun.
Let Yahoo! FareChase search your favorite travel sites to find flight and hotel bargains.