#118 words.db: pagesize problem

resolved
closed-works-for-me
htdig (103)
5
2002-06-04
2002-05-03
Anonymous
No

I am getting the following error message from htsearch:

DB2 problem...: /usr/local/htdig/db/cuws.words.db: file
size not a multiple of the pagesize

I am using htdig 3.1.6, built using gcc 2.95.3 on
Solaris 2.6 on an ultrasparc 2 box.

The pagesize is 8192 and, indeed, the size of
cuws.words.db is not a multiple of 8192.

I stared at the db code for a time but am none the
wiser. I can find no calls to get_pagesize in that
code. How is the pagesize set? Somehow the db write
code is able to write a db file that the db read code
cannot read!

Discussion

  • Gilles Detillieux

    • milestone: --> 103281
    • assigned_to: nobody --> grdetil
    • status: open --> closed
     
  • Gilles Detillieux

    Logged In: YES
    user_id=149687

    I believe the most common explanation of this error on UNIX
    systems is that the database got truncated due to filling up
    the disk or exceeding your quota. Try with a bigger quota
    and/or larger disk volume and see if the problem recurs. If
    you've clearly ruled out both of these conditions, and the
    problem still happens on a fresh, new database, let us know.
    Hopefully before too long, we will have the latest mifluz
    code rolled into htdig, which should eliminate some other
    causes of spurious words.db file corruption.

     
  • Nobody/Anonymous

    Logged In: NO

    The htdig run was done as root (no quota), on a volume with
    34 gbytes free, and it was a database freshly created. Sorry
    I did not specify this before.

     
  • Gilles Detillieux

    Logged In: YES
    user_id=149687

    According to Paul Lyon:
    I recently reported a bug about getting an error message from
    htsearch about the file size of the words.db file not being
    a multiple of the page size. This turns out to have been caused by a
    version mismatch between htsearch and htmerge, in turn caused by my
    failing to specify the "prefix" properly (to "/usr/local" instead of the
    default "/opt/www") when running configure. I have recently built the
    latest 3.2.0b4 snapshot with --prefix=/usr/local to configure, and then
    rebuilt two search databases. Now htsearch seems to work fine with
    these.

    Sorry to file a bogus bug report. Please disregard same.

     
  • Gilles Detillieux

    • milestone: 103281 --> resolved
    • status: closed --> closed-works-for-me
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks