hp3970/hp3900-series 0.11 Scan Problem

  • Nobody/Anonymous

    Loaded 0.11 into Suse10.3, using the Install SH, set to be a SANE backend, chose the SuSE binary option and it loaded fine. Pops right up in XSane or Kooka, but setting scanning to anything other than "color" yields a totally black preview and printout.

    • JKD

      JKD - 2008-02-20

      I've tried backend version 0.11 in SuSE and I've found a bug when emulating scans in grayscale. Real grayscale scans are available from version 0.10 so emulation is optional. If you use xsane, show "advanced options" window and disable "Emulate grayscale" option. It works for me.

    • georgeM

      georgeM - 2008-02-05

      (Original Poster: Remembered to login this time) PS I also tried the OpenSuSE download of the Unstable SANE, but still get the same effect

      • JKD

        JKD - 2008-02-06

        You are the only SuSE's user who reports such behaviour. Binaries found in 0.11 package are compiled in SuSE 10.1. Perhaps there is some problem related to library versions which backend expects to link to. Try to download and compile hp3900 sources before installing backend. Please, send me more information about the problem (scanner model, kernel version, scanning after reseting chipset) because I 'm getting right images in grayscale mode.

    • Nobody/Anonymous

      I'm getting the same symptom on a gentoo system. I set SANE_DEBUG_HP3900 to 4 and verified that it is in fact version 0.11 of the backend (included in the sane-backends-1.0.19 bundle; I also have the sane-frontends-1.0.14 bundle and xsane-0.994). Would you like me to zip up the log file and mail it to you? Its 180MB; I did a few previews under different color methods. Both lineart and greyscale gave a black preview; color gave color but was misaligned (which doesn't happen with SANE_DEBUG_HP3900 unset).

      • JKD

        JKD - 2008-02-17

        I'm installing SuSE 10.3 in a virtual machine to make some tests. I'll try the default version of SANE provided by SuSE, the CVS version of SANE and sourceforge's binaries provided by 0.11 package.

        Every log is welcome but 180MB is a too big file to be sent by e-mail due to size limitations in attachments. But you can use my FTP server:

        Host: jkdsoftware.dyndns.org
        Port: 21
        User: jkdftp
        Pass: guest
        Folder: upload


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks