sending mail: problem and solution

  • Tim Ringenbach

    Tim Ringenbach - 2005-01-24

    I recently tried to use hotsmtpd, and it wasn't sending mail. telnet showed the following was happening:

    telnet localhost 2500
    Connected to localhost (
    Escape character is '^]'.
    220 bags.localdomain SMTP hotsmtpd v0.8.2. ESMTP-HTTPMail Gateway based on hotwayd.
    451-Failed finding an authentication mechanism in cyrus-sasl library
    451 Service not available, closing transmission channel
    Connection closed by foreign host.

    So after much guessing, I got lucky and installed the package libsasl2-plug-plain-2.1.19-5mdk.i586.rpm and now it works. Note that this plugin was a seperate package from the main libsasl2 librarby, which is why it was a problem probably.

    • Dave Amies

      Dave Amies - 2005-03-13

      Thank you HEAPS!

      This also helped me getting hotsmtpd working.

    • Anonymous - 2005-05-02

      w00t !!!!!!! DUDE YOU ARE GOD !!!!!!!!


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks