modules.cgi in FC5/perl 5.8.8 problem

David S.
  • David S.

    David S. - 2006-06-26

    modules.cgi detected most of the missing modules correctly.  I installed the one it told me I was missing and had no problem with that.

    However, after installation I tried running some stuff and it gave me internal server errors whenever  I would try to (for instance) add a hosting server.

    From a command line I typed in    perl (in the mods directory) and I got the following error:

    Can't locate Net/SSH/ in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at line 1.
    BEGIN failed--compilation aborted at line 1.

    I did a locate (after running updatedb) to see if I could find the files and the files didn't exist anywhere on my machine.  I'm not exactly sure what would have caused that to happen, as the source code for modules.cgi seemed correct.  Perhaps that's a FC5 or a perl 5.8.8 bug, but just so people are aware of it, that they may need to install Net::SSH::Perl even if appears to be installed.  I ran perl on all of the module files just to see if any other modules were missing.  It appeared to be the only one.

    • David S.

      David S. - 2006-06-26

      oh and I forgot to mention that the package I installed was


      • Carl L. Thompson Jr.

        Its my personal recommendation that you use the installer as its much more friendly than the RPM packages.  RPMs just aren't very flexible where the installer will install it where you want it and remember where you installed it so its easy to upgrade with next release.

    • Jinkler

      Jinkler - 2006-07-28

      FWIW, I am having an incredibly difficult time getting this package installed.  The installer isn't consistent (it looks for admind in /usr/sbin despite where the installer script was told, for example), the init.d scripts don't work (SuSE, for example, doesn't launch with 'daemon' and has no 'status' command line entry.) 

      Having spent several frustrating hours trying various combinations and running into any number of issues (one component couldn't install because it needed perl > 5.0053, despite the systems having 5.8.8.)  The Rijndael component alone took up a few hours in tracking down and proper version checking within various bits and pieces.

      I've even tried going to previous versions but I suspect the earlier installs have scribbled so many places at this point, a reload of the system is the best next step.  Typically, I wouldn't have spent so much time on something like this, but the package looks really quite impressive.  If anyone manages to get it up and running under 10.1, post the secrets to success (or the RPM).


Log in to post a comment.