Initial Login

Support
2005-02-02
2013-04-15
  • John Fairbairn

    John Fairbairn - 2005-02-02

    I dont know quite whats going on here, but if anyone's got any ideas I'd appreciate the help. I have done all the preliminary steps to installing hosting-helper and have run the modules.cgi ... i get:
    Module Evaluation for GNU Hosting Helper
    Required Modules
    Crypt::CBC     Checking for Crypt::CBC, OK (version 2.12)
    Crypt::Rijndael     Checking for Crypt::Rijndael, OK (version 0.04)
    Mysql     Checking for Mysql, OK (version 1.2401)
    IO::Socket     Checking for IO::Socket, OK (version 1.27)
    MIME::Base64     Checking for MIME::Base64, OK (version 3.05)
    URI::Escape     Checking for URI::Escape, OK (version 3.28)
    Optional Modules for Authorize.net
    Crypt::SSLeay     Checking for Crypt::SSLeay, OK (version 0.51)

    So all seems ok. I go to the https://somedomain.com/admin.cgi and get a prompt to add a user. So i do. this bounces me to login page as it should. The problem is when i try to log in with the user I just created, it bounces me back to the setup page where
    i added the user. So i try to add the user again, same deal. Round in a circle I go. But can't log in. I have also checked my error logs and i get no errors. Any ideas?

    Specs = CentOS 3.4, perl 5.8.0, pretty much stock server install.

    Thanks all, looks like a great product. Wish i could get into mine.

     
    • John Fairbairn

      John Fairbairn - 2005-02-02

      woops that url i typed above is a type-o... i go to https://somedomain.com/cgi-bin/admin.cgi
      any ideas?

       
      • Carl L. Thompson Jr.

        My best guess without more information is that your either running it as the main website or not using apache with suexec.

        If this is indeed the case then its simply a permissions issue.

        Find out what user the cgi is being executed as and make sure the directory and all files in it are owned by that user.

        On most default redhat based installations the user is nobody.

        Basically what is happening is the user executing the script doesn't have permission to write the information to file about the login data.

         
    • John Fairbairn

      John Fairbairn - 2005-02-02

      Yup that did it, always something so simple. Thanks very much for a quick reponse. Much appreciated.  :D

      linux_terror

       
    • Wickedinterface

      Wickedinterface - 2005-02-22

      I am having the same problem as linux_terror but i am not fully linux savy yet. How do I make the nobody user have the correct permission

       
    • Wickedinterface

      Wickedinterface - 2005-02-22

      ok fixed it forgot permission on one dir

       
    • Fred

      Fred - 2007-03-04

      I am having the same problem (after 4 installs).  My problem is that I am a newby, and the comments made to resolve this mean nothing to me.

      Could someone please give me specific details as to what I am meant to be looking for or what I am meant to be doing then that would be appreciated.

      Regards

      Fred

       
    • Fred

      Fred - 2007-03-04

      I have managed to resolve my login problem.

      With FC5 the /var/www/cgi-bin folder is owned by root:root with permissions set to 644
      I set the permissions to 777 on the folder only.

      I don't know what impact this will have in general terms of use and security on my server, but it got me going.

      Regards

      Fred

       
    • Carl L. Thompson Jr.

      I recommend setting ownership of /var/www/cgi-bin to apache:apache (chown -R apache:apache /var/www/cgi-bin)

      Then chmod 755 /var/www/cgi-bin

      This is more secure than making cgi-bin world writable.

      Redragon

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks