Problems with salt again

Support
dodger
2006-08-17
2013-04-15
  • dodger

    dodger - 2006-08-17

    hi,

    i just install 2.05 on some clean servers. (debian etch)
    admin & client runs.

    hhelperd makes roblems when upgrading the db (pushing config & .inc file worked)

    i checked modules versions, cause that was mentioned here, Crypt::CBC, OK (version 2.18)

    apache error log on administrator says:
    Ciphertext does not begin with a valid header for 'salt' header mode at /usr/lib/admin/admin.cgi line 2186

    hhelperd -debug=3 says:
    Invalid default value for 'id' at /usr/lib/perl5/Mysql.pm line 175
    (wich seam logical, if it doesn't get correct credentials. )

    any idea ?

    cheers,

    dodger

     
    • Carl L. Thompson Jr.

      I've seen similar issues with debians crypt::cbc package.  If you install crypt::cbc from CPAN and redo the configurations it should solve the problem.

       
    • Corey Seliger

      Corey Seliger - 2006-08-19

      I have a fresh install on CentOS 4 using the CentOS yum repsository and the version of perl-Crypt-CBC that is in the gnuhh repo...

      Here is what I am getting:

      [Sat Aug 19 14:03:49 2006] [error] [client 1.2.3.4] Ciphertext does not begin with a valid header for 'salt' header mode at mods/domain.pl line 3452, referer: https://\*****/cgi-bin/admin/admin.cgi?do=add+domain
      [Sat Aug 19 14:03:49 2006] [error] [client 1.2.3.4] Premature end of script headers: admin.cgi, referer: https://\
      *****/cgi-bin/admin/admin.cgi?do=add+domain

      I was in the administrative interface trying to add a domain for myself.

      Any help or ideas how to work past this would be appreciated.

       
    • Carl L. Thompson Jr.

      jump on irc, you shouldn't be having any encryption problems with that setup.  We'll have to work thru it in real time and see if we can track the problem down.

       
    • Korponai

      Korponai - 2006-09-27

      seliger:
      I have similar problem when adding domain in hosting helper

      i am getting in error log:
      Ciphertext does not begin with a valid header for 'salt' header mode at mods/domain.pl .....

      Any help or brainstorm ?!
      10x

       
    • Carl L. Thompson Jr.

      Are you running Crypt::CBC 2.18? If so was it installed before upgrade?

      Did you send the configuraton to the hosting server?

       

Log in to post a comment.