Some DIR Questions

Help
2014-09-03
2014-09-06
  • Chuck Moore

    Chuck Moore - 2014-09-03

    Hi Mark,

    1. Is there a profile for the DIR command ?
      When I do a DIR command, I'd like to have the directories sort to to the top. Something like 'SORT * 1 10 38 150' would achieve. Is this possible ?

    2. I built a (popup) menu that created a list/menu of currently-accessed disks that would allow mouse-clicked navigation throughout all directories on all disks. In case I re-invented something: Is there a feature on the DIR command which does this already ?

    Finally, thanks very much for all your effort on this (THE) program/utility. In my experience, through two decades of use, it has been invaluable on countless systems and platforms: when other software environments/tools are unsuitable/unavailable/unstable, THE can be relied upon.

    Chuck

     
  • LesK

    LesK - 2014-09-04

    Chuck:
    1-Add: if initial() then 'set defsort directory' to your profile
    BEFORE any 'set reprof on'.
    2-Not that I know of. I do have a macro that shows a popup of your
    configured 'favorite' disks/directories so you can easily choose one without
    having to deal with disks/directories you're not interested in. If the disk
    or directory isn't there, nothing appears. Kinda handy for moving between
    (mostly) similar pc's and handling flash drives.

     
  • Chuck Moore

    Chuck Moore - 2014-09-04

    Les -- Thanks for the quick response. I added, per your suggestion, the 'set defsort directory' to my profile.

    By the way, do you know what/how THE checks to see if (any) REXX is installed ? I re-installed OOREXX about a month ago and since then THE has (using the QUERY REXX command) been saying 'NONE'. I'm running Win-7 Professional. My REXX_HOME variable is set correctly. REXX_HOME is in the PATH. Yet, THE doesn't find REXX.

    Chuck

     
  • LesK

    LesK - 2014-09-04

    Sorry, I have no idea. Can you run Rexx programs from a Windows
    command window?

     
  • Chuck Moore

    Chuck Moore - 2014-09-05

    Morning Les,

    Yes, from both CMD and PowerShell windows. I have programs with file-extensions of OREXX, as well as the standard REX extension, and both sets of files/programs execute normally.

    I've tried re-installing REXX (twice). Can't remember if I tried re-installing THE. (sigh)

    Ah well, when Mark gets the new, GUI version of THE ready-for-production, I'll install it and see what happens. Thanks for your assistance.

    Chuck

     
  • LesK

    LesK - 2014-09-05

    Mark is back from vacation, so as soon as he can I'm sure he'll
    provide an answer.

    I'm beta testing 3.3RC4 and there are some nice features there.
    I can't use the new graphical interface because of my vision
    impairment.

     
  • LesK

    LesK - 2014-09-06

    Chuck: Any chance you installed 64 bit ooRexx? Check by using a
    command window and do:

    rexx.exe -v

    If it's 64 bit, uninstall it and install the 32bit version.
    You might also check in Task Manager that RXAPI is running as a
    Service (just guessing).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks