new -s switch

  • posso20

    posso20 - 2007-01-21

    Hi !
    I switched my HD to power-up in standby mode by using the a.m. switch.
    Now I've trouble every time when I startup the computer because the HD
    isn't recognized. If I use the -s0 switch I get the message
    'HDIO_DRIVE_CMD(powerup_in_standby) failed: Input/output error'. How can I
    get back my HD to active on power-up. The HD is an Western Digital WD1600JS (SATA).

    Thanks in advance for help

    • keke

      keke - 2007-01-27


      Im have the exact same problem, with my Hitachi 7k250 1650gb and 2x WD2500JD discs.

      How do i spin them up again?

      • keke

        keke - 2007-02-05

        I fixed my Hitachi disk by setting the jumper on the power in standby mode. That way i could change the flag with hdparm. And remove the jumper again and it worked. But my Western Digital disc are not so willing.

    • Xavier Callejas

      Xavier Callejas - 2007-02-20

      I have the very exact problem too!

      I need to restore my HD, please help me!

      I have a Toshiba laptop, how could I set the jumper on the power in standby mode?

      The BIOS setup doesn't give any choice about the disk.

      I enter to a linux console recuperation and I try to:

      #hdparm -s 0 /dev/hda
      setting power-up in standby to 0 (off)
      HDIO_DRIVE_CMD(powerup_in_standby) failed: Inpu/outpu error

      Meanwhile my laptop BIOS do not recognize the disk.

      Thank you.

      • keke

        keke - 2007-02-21

        As far as i remember laptop harddrives doesn't have jumpers.
        So i don't think you can save your disc. Sorry.

    • Xavier Callejas

      Xavier Callejas - 2007-02-24


      In a deseperaly try I wrote to Mark Lord <mlord at> the developer of 'hdparm' and he solve this problem by sending me a copy of 'hdparm' that has a patch made by him. With this copy of 'hdparm' you can do 'hdparm -s0 /dev/hda' and the problem is solved (I had to reboot and then again do 'hdparm -s0 /dev/hda' to make the change permanently).

      All came to normaly.

      I you like, I could send you this copy of 'hdparm' pached by Mark.

      If the HD broken is the one who boot your system you most use a 'Recovery linux console' or a liveCD to enter to a linux console, then run the patched hdparm program.


      • keke

        keke - 2007-02-24

        Yes please. I would like to try that patch. I still have 2 western digital discs that doesn't work.
        chrklin at

        • Xavier Callejas

          Xavier Callejas - 2007-02-24


    • posso20

      posso20 - 2007-02-24

      good news finally! please send me this patched hdparm too. - thanks !

      • Xavier Callejas

        Xavier Callejas - 2007-02-24


    • Mark Lord

      Mark Lord - 2007-03-22

      >As far as i remember laptop harddrives doesn't have jumpers.

      Travelstar drives *do* have a standy pin.  Not a jumper, just one pin.

      It is the top pin closest to the right-hand edge of the 44-pin connector.
      This pin has to be connected to ground to force the hardware version
      of "poweron-in-standby".


      • Xavier Callejas

        Xavier Callejas - 2007-03-22

        wow! thanks.

        So this ping connected to ground is just when your travelstar is locked?

    • Mark Lord

      Mark Lord - 2007-03-22

      Okay, I have now created two bootable images that should cure this problem.

      turn_off_poweron_in_standby.flp is a bootable floppy disc image, and
      turn_off_poweron_in_standby.iso is a bootable CDROM image.

      Boot from either of these, and a custom kernel should find all of your drives and spin them up.  It will also try to do an automatic "hdparm -s0" using two different methods.

      It works for me.



    • ub_

      ub_ - 2007-06-22

      Thanks Mark for turn_off_poweron_in_standby. I tried it after I had bricked my two Samsung disks with hdparm -s1.  Unfortunately, turn_off_poweron_in_standby seems dependent on the BIOS' capability to detect the drives, so it did not detect my two drives, but just reported "port failed to respond (Status 0x80)".

      Svend Olaf Mikkelsen's "findpart" utility finally revived my disks.  It can be found here:  "Findpart" seems to ignore the BIOS and talk to the IDE channels directly, which worked like a charm even if the BIOS had not detected the standby drive in the first place.


    • christophe34

      christophe34 - 2007-10-20

      Too bad for me : I misspelled -S 2 with -s 2 and blocked my Samsung HD400LD (was on a kurobox NAS). I tried both turn_off_poweron_in_standby + findpart on different hardware (VT8366/A/7 [Apollo KT266/A/333] + olde Intel PII based PC) , but no success. It seems that the disk is really dead now :-(((


      • Xavier Callejas

        Xavier Callejas - 2007-10-20


        Mark Lord sent me a hacked version of hdparm that fixed my problem, if you like I could send it to by email.


        • ste_pb93

          ste_pb93 - 2007-10-23

          Thanks that would be great, could you email it to please ?

    • casueps

      casueps - 2007-11-25

      I have the same problem with a Western Digital WD2500JS. I can't do hdparm -s0 with that disk because it isn't recognized, and the /dev/sdb file doesn't exist.
      I tried the boot floppy and it works (I can hear it spinning up), but when it ends it says I have to reboot without powering off the machine, and I can't!! The box doesn't have a reset button and ctrl+alt+del doesn't work. Why don't they put reset buttons anymore??

      I think you should change the boot floppy so that it reboots the machine when you press enter, in case the user doesn't have a reset button.

      Could someone send me the patched version of hdparm? My address is casueps at


    • Jaime Lima

      Jaime Lima - 2008-05-01


      I am another one in business of transforming HDs into bricks. The linux kernel 2.6.23 is able to spin and mount it (kernel version 2.0.22 spins it but doesn't create the /dev/sdX devices for it. kernel version 2.6.18 doesn't spin it, but works fine if someone spins it by other means before). I downloaded the latest version of haparam but the 'hdparm -s0' is failing. I've looked into the src code. Both calls driven by the parameters below are failing:
      #Line  hdparm.c
      #1292                         __u8 args1[4] = {ATA_OP_SETFEATURES,0,0x07,0}; /* spinup from standby */
      #1306                 args[2] = powerup_in_standby ? 0x06 : 0x86; /* {ATA_OP_SETFEATURES,0,0x86,0} when the parameter -s0 is passed */

      After the driver is spinning, the BIOS seems to recognize it (it the hd is not spinning the BIOS  identifies that `something` exists on other side the SATA cable, but the drive same/geometry is not shown.

      Any new ideas of how to solve this?

  • Jools Wills

    Jools Wills - 2015-01-15

    Apologies for posting to an ancient thread, but I have a pile of western digital WDC_WD5000AAKS that were set to spin in in standby mode. This was fine for their previous purpose, but now I would like to switch this setting off. However I too am getting the error:

    hdparm -s0 /dev/disk/by-id/ata-WDC_WD5000AAKS-22TMA0_WD-WCAPW3279823

    spin-up: setting power-up in standby to 0 (off)
    HDIO_DRIVE_CMD(powerup_in_standby) failed: Input/output error

    Earlier in the thread there was mention of a patched hdparm - is this still available (or the patch) ? Maybe it could be put somewhere public or incorporated into hdparm ? if anyone has the patched version, please send it to buzz [at] - thanks.

  • Jools Wills

    Jools Wills - 2015-01-15

    Q17: Western Digital WD5000KS doesn't spin-up (firmware bug).

    A17: Taken over from Google Notebook.
    If any controller or software you have enables the "Power-up in Standby" feature on these drives, you can not disable it. In fact, once that mode is enabled, the drive reports conflicting information.
    Western Digital said on the phone the KS line of drives are not a high-enough priority for them to fix the firmware.

    oh dear.. :) Luckily the disks are not important, but I was going to blank them and give them away or something, but not so much use now.

  • Jools Wills

    Jools Wills - 2015-01-15

    Seems there is a fix - requires an dos tool / bootdisk etc.

    Shame there is no fix that would work on linux - or maybe that is what the patched hdparm mentioned earlier in the thread does (which does not seem to be available anywhere :( )


Log in to post a comment.