hdparm -t doesn't match up with other tests

  • John Klassa

    John Klassa - 2009-09-01

    Put in a 500GB WD drive last night.  When I run "hdparm -t /dev/hde" on it, I get:

    Timing buffered disk reads:    4 MB in  3.31 seconds =   1.21 MB/sec

    (which is pathetically slow performance).

    Yet, when I do other things -- like copy a 400MB file to /tmp in 20 seconds -- it seems to me that the read speed has to be way more than the 1.21 MB/sec that hdparm reports.

    Odd thing is, for my other drives, hdparm shows numbers that make more sense (like 50MB/sec for my older, 160GB drive).  For this drive, though, hdparm reports really, really bad numbers.

    Any thoughts on what to try next, to see whether hdparm is confused, or whether the drive really sucks (despite the fact that copying data off of it seems to work reasonably quickly)?

    • Mark Lord

      Mark Lord - 2009-09-01

      Something you are doing is confused.  There could have been something else (like updatedb) running during your -t attempt, or goodness knows what.  Just try it again, on a totally inactive system.


    • John Klassa

      John Klassa - 2009-09-01

      I can do this consistently...  Almost no load on the system.  I run "hdparm -t" on the two drives and get 50+ MB/sec on the old one and around 1-2 MB/sec on the new one.  Then, I turn around and do a "time cp bigfile /tmp" and see speeds of 20-30 MB/sec once the math is done.  Over and over.  I agree that it's odd :-), but I don't think it's anything I'm doing (or letting happen in the background).


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks