Linux Red Hat 8.0 Compilation problems

Help
2002-12-24
2003-08-04
  • Mark T. Johnson

    Mark T. Johnson - 2002-12-24

    I'm a bit of a newbie at this, so bear with me. I downloaded the 2.1.2 source and ran "configure" then "make". There were compilation warnings and 2 errors, so the "make" failed.

    I suppose may not have the proper environment for development, but it works for C-code compilation, and is pretty much straight out of the box RedHat 8.0.

    Based upon the messages I got, maybe the configure step has set up my Makefiles incorrectly??? Please help, I'd love to try
    your tool out!!!

    Thanks,
    Mark

    Below are the warnings and errors in compiling hammerhead.cc.
    ---------------------------------------------------------------------

    cc1plus: warning: changing search order for system directory "/usr/include"
    cc1plus: warning:   as it has already been specified as a non-system directory
    In file included from /usr/include/c++/3.2/backward/list.h:59,
                     from scenario.h:20,
                     from hammerhead.cc:34:
    /usr/include/c++/3.2/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <sstream> instead of the deprecated header <strstream.h>. To disable this warning use -Wno-deprecated.
    hammerhead.cc: In function `int ReadScenarios()':
    hammerhead.cc:236: no match for `dict_iterator<Scenario*>& !=
       dict_iterator<Scenario*>' operator
    hammerhead.cc:250: no match for `dict_iterator<Scenario*>& !=
       dict_iterator<Scenario*>' operator
    hammerhead.cc: In function `void testScenarios()':
    hammerhead.cc:553: no match for `dict_iterator<Scenario*>& !=
       dict_iterator<Scenario*>' operator

     
    • Anonymous - 2003-01-07

      hi,

      have the same result on a suse.81 box
      i tried tarballs to compile

      hammerhead-2.1.0
      hammerhead-2.1.1
      hammerhead-2.1.2

      but the make fails by all version compiling the
      src/hammerhead.cc

      are something wrong o my system

      please help, i will also try out
      this tool
      thanks
      andi

       
    • PolarFox

      PolarFox - 2003-01-31

      Same here, using slackware 9.0 beta, gcc-3.2 and all the latest thingies :) newest glibc... etc...
      any ideas what goes wrong?

       
    • Ryan Pump

      Ryan Pump - 2003-02-25

      Mark,

      I had the same problems running on SuSE 8.1 (which I did not see on SuSE 8.0). My understanding is that 8.1 uses the latest version of the gcc compiler causing the errors you see. (whereas previous Linux distributions do not).

      To get around the problem you're facing I added the following lines in dict_iterator class in dictionary.h:

      inline bool operator!=(const dict_iterator &it1)
      {
         return ! (*this==it1);
      }

      This should resolve the problems you were seeing in the 3 lines in hammerhead.cc above.
      Hope this helps, cheers.
      Ryan

       
    • Geoff Wong

      Geoff Wong - 2003-03-03

      I've added the above fixed and removed the warnings from the newer gcc compiles, currently checked into cvs. Will build a new package shortly.

       
    • Eugene Sotirescu

      Still problems making under RH 8:
      First a zillion
      cc1plus: warning: changing search order for system directory "/usr/include"

      then:

      In file included from /usr/include/openssl/evp.h:89,
                       from /usr/include/openssl/x509.h:67,
                       from /usr/include/openssl/ssl.h:69,
                       from connection.h:16,
                       from scenario.h:26,
                       from hammerhead.cc:34:
      /usr/include/openssl/des.h:193: declaration of `char* crypt(const char*, const
         char*)' throws different exceptions
      /usr/include/unistd.h:946: than previous declaration `char* crypt(const char*,
         const char*) throw ()'

      and here it dies

       

Log in to post a comment.