Problems installing on Solaris 8

  • Anonymous - 2001-09-18


    I ran the config script, and tried "make", but
    it seems to bomb on the very first compile.

    The result is:

    cd src; gmake
    gmake[1]: Entering directory `/home/SHARE/hammerhead-2.1.0/src'
    g++ -MM  -D_REENTRANT -DSunOS > depend.tmp
    sed -e "s+^.*:+obj/SunOS/&+" depend.tmp > obj/SunOS/.sdepend
    rm -f depend.tmp
    Dependencies Rebuilt
    gmake all
    gmake[2]: Entering directory `/home/SHARE/hammerhead-2.1.0/src'
    g++  -c -D_REENTRANT -DSunOS -o obj/SunOS/config.o In function `int OpenConfiguration()': `INADDR_NONE' undeclared (first use this function) (Each undeclared identifier is reported only once for each function it appears in.)
    gmake[2]: *** [obj/SunOS/config.o] Error 1
    gmake[2]: Leaving directory `/home/SHARE/hammerhead-2.1.0/src'
    gmake[1]: *** [first] Error 2
    gmake[1]: Leaving directory `/home/SHARE/hammerhead-2.1.0/src'
    make: *** [src] Error 2

    Any ideas?  I tried overriding the include file
    path, but that didn't help.

    Is this supported on Solaris 8??


    • Geoff Wong

      Geoff Wong - 2001-09-19

      Strange it's not defined by default, I should have access to a netra shortly so I'll try to get it compiling cleanly there. For now add the following somewhere:

      #ifndef INADDR_NONE
      #define INADDR_NONE 0xffffffff

      That should probably do the job.

      • Anonymous - 2001-09-19


        Thanks, but the root of the problem is that
        the build is not finding the system include
        netinet/in.h , (which defines INADDR_ANY).

        I didn't see any -I paths in the compile line.
        Where is the make getting its scripts from?


        • Geoff Wong

          Geoff Wong - 2001-09-20

          It shouldn't need any -I paths to find <netinet/in.h> as that should be in the standard include path (/usr/include). I've just checked a solaris box and I could include netinet/in.h but it doesn't define INADDR_NONE, but does define INADDR_ANY. If the include isn't in a standard place then you should be able to edit src/Makefile (after configure) and add in some extra include directives into the SunOS section. I must clean that section of the Makefile up at some stage anyway.

    • liv34h1m

      liv34h1m - 2005-06-15

      Having similar problems with the latest release on Solaris 10 for x86 systems.  Please advise the fix to resolve.  I have added some extra include directives to the make file and the problem still exists.  Any assistance would be helpful.


Log in to post a comment.