Help: using SR-SP2 with GXSM on Ventiotec's Ubuntu 12.04

  • Cassiano Rabelo

    Cassiano Rabelo - 2014-02-17


    At our lab we are trying to setup a new STM system using GXSM and a Signal Ranger SR-SP2 board.

    I have downloaded and installed the very handy linux-distribution by the folks at (Ubuntu 12.0.4 LTS).
    If I plug my Signal Ranger SR-SP2 to the USB port, I see it being added to the /dev/ folder (/dev/sranger0). I'm also able to send instructions to it using the "loadusb -m" command. But if I open GXSM and choose "SRANGER:SPM" as the "Hardware/Card" (this is what I should do, right?) and restart GXSM, it no longer launches. I only get the following in my terminal session and then I'm back into the command prompt:

    GXSM-DebugLevel/PI-DebugLevel/ForceGDefaults: 0/0/0
    DSPDev :/dev/sranger0

    I'm wondering if this has anything to do with the firmware update file that is placed in the desktop by the linux installer (firmware for STD_SP2 version 1058.out). How do we use/apply this firmware update?

    Any help will be greatly appreciated.

    Best regards,
    Cassiano Rabelo

  • Percy Zahl

    Percy Zahl - 2014-02-18


    sorry for the confusion, for all newer DSP (Mk2, Mk3-Pro) the loadusb tool is not needed any more and also won't work for flashing (debugging only).

    Instead you have to install and use the "minidebugger" tool (Windows) supplied by SoftdB to program the DSP Flash once (and/or update later) with the DSP SPM control code binary.
    When the flash/programming of the DSP is finished, close the mini debugger, unplug and power-cycle!! the DSP.

    Then it's ready for gxsm2 and will be detected and accepted.

    Find the DSP SPM control code binary file "FB_spmcontrol.out" (for the MK2, matching to the gxsm2 version you are using, it should be in the "SRanger/TiDSP.../MK2-A810.../ folder on the life CD.

    You do not need to re flash the FPGA support code.


  • Percy Zahl

    Percy Zahl - 2014-02-20

    Hi Cassiano Rabelo again,

    holy.... sorry -- I just realized you were actually talking about the old SR-SP2.

    Yes "SRANGER:SPM" this is right.

    But you also must MANUALLY load the DSP code before, with the SP2 you can exactly follow the manual how to load/start the DSP code. This is unchanged and the DSP must be up and running as you can any time quite and restart/reconnect via gxsm while the DSP and all feedback/scan/... is undisturbed continuing.

    The SP2 can be loaded using the via loadusb but (as long it stays powered it will keep running) -- but to flash it for "autostart" at power up you need the SoftdB minidebugger:

    The SP2 can be flash programmed as well using the SoftDB tools. I am not sure if they are still online available as the SP2 is totally outdated. You may ask SOftdb directly for them.

    Also in gxsm you will have to adjust the "newer" default settings quite a bit, follow the manual to revert to the old -- it should still all work even I have not used it in a while.


  • Cassiano Rabelo

    Cassiano Rabelo - 2014-02-20

    Hello Percy.
    First of all, thanks a lot for replying.

    I was able to flash program the SP2 using SoftDB tools. I talked to Mr. Alex from SoftDB and he sent a minidebugger that works with the SR-SP2.

    I flashed it with the file named "firmware for STD_SP2 version 1058.out" that was in the desktop of the Ubuntu 12.04 by Ventiotec.

    You said:

    Also in gxsm you will have to adjust the "newer" default settings quite a bit, follow the manual to revert to the old -- it should still all work even I have not used it in a while.

    What kind of settings are we talking about? You mean timing and output mappings? Will the old settings be available in the manual?

    Thank you once again!
    Best regards,


  • Percy Zahl

    Percy Zahl - 2014-02-25

    Yes, see DSP subsystem "Signal Ranger", page 277 ff. Table 28.1

    Last edit: Percy Zahl 2014-02-25
  • Cassiano Rabelo

    Cassiano Rabelo - 2014-02-27
    Post awaiting moderation.
  • dev renjith singh

    can you sen me the minidebugger you used . also help me with the steps to run firmware for STD_SP2 version 1058.out and flash it .i am facing this problem while running.. kindly help me..

    GXSM-DebugLevel/PI-DebugLevel/ForceGDefaults: 0/0/0
    DSPDev :/dev/sranger0
    SR-MK2/3_HwI HardwareInterface Init
    probing for MK2...
    HWI-DEV-MK2-I HwI SR-MK2 probing
    HWI-DEV-MK2-E01-- can not open device >/dev/sranger0<, please check permissions.
    Error: No such file or directory
    HWI-DEV-MK2-E01-- can not open device >/dev/sranger0<, please check permissions.
    probing mark id: MK--1 identified.
    HWI-DEV-MK2-BYBY -- closing all DSP links.
    probing for MK3...
    HwI SR-MK3 probing
    HWI-DEV-MK3-E01-- can not open device >/dev/sranger0<, please check permissions

  • Thorsten Wagner

    Thorsten Wagner - 2014-03-29

    Please try the script which will try to set the permissions and upload the DSP-code. For automatic uploading of the DSP code this has to be in a proper place, e.g. ~/Sranger/TiCC-project-files/FB_spmcontrol/FB...

    You can run the loadusb (in the Folder ~/SRanger/loadusb64) in a Kind of debug mode by the option -t.

    You can also change manually permissions:

    sudo chmod 777 /dev/sranger0

    Thorsten :-)

    • dev renjith singh

      Thank you for the reply

      i tried using sudo chmod 777 /dev/sranger0

      sudo chmod 777 /dev/sranger0
      chmod: cannot access `/dev/sranger0': No such file or directory

      when running SRanger/loadusb64) i got
      COFF2 Loader/Terminal Emulator for Signal Ranger SP2/USB
      Version 0.10, Copyright (C) 2002,2003 Percy Zahl
      Loadusb comes with ABSOLUTELY NO WARRANTY; for details type loadusb -W'. This is free software, and you are welcome to redistribute it under certain conditions; typeloadusb -W' for details.
      COFF file [.out]:
      Error: open device </dev> failed, reason: No such file or directory
      please check:
      -> that the device exists and has proper access rights
      -> that the kernel module loaded
      -> the USB connection to SignalRanger
      -> that the SR-SP2 is powered on
      -> use option -d /dev/... to specify path to other device

      i used the commend
      lsmod | grep usb_sranger
      usb_sranger_mk23 33895 0

      but its showing the device.

      please help me with this.

      while runnig i got

      nodevice/device/sranger0 found

      Device SR_MK2 found!

      Magic ID:EE01
      SPM version:2022
      Software iD:1001
      DSO Code Released:12.05.2011

      Upload of the DSP Code to
      the SR-MK2 not possible yet.

      please use the Minidebugger
      under windows shiped with your

      this is what i am getting when running in terminal.

  • Thorsten Wagner

    Thorsten Wagner - 2014-04-02

    I though that you have a SR-SP2 not an mk2 board. You have a smart piezo driver form softdb or a PLL? Please, clarify what kind of hardware you are using!

    The minidebugger mentioned by the initSR script is, by the way, the Windows one from softdb. I misinterpreted you posting that you are looking for a Linux version. After installing the package you will find the tool in your Windows start menue under SignalRanger_mk3->SR3_Application->SR3_minidebugger

    Right now I recommend to use the tool SignalRanger_mk3->SR3_Application->SRx_Analog810_SelfTest to update the DSP Firmware. But in case that you have more than one softdb device make sure that only the one is attached which you want to Flash!!!

    Thorsten :-)

  • Thorsten Wagner

    Thorsten Wagner - 2014-04-02

    By the way: You do not have the kernel modules installed for your SR-SP2. Please try either

    sudo dpkg-reconfigure sranger-modules-std-dkms


    sudo apt-get install sranger-modules-std-dkms

    Thorsten :-)

  • dev renjith singh

    i tried sudo dpkg-reconfigure sranger-modules-std-dkms

    Loading new sranger-modules-std-0.0.1 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.2.0-60-generic-pae
    Building for architecture i686
    Building initial module for 3.2.0-60-generic-pae

    Running module version sanity check.

    Good news! Module version for usb-sranger.ko
    exactly matches what is already found in kernel 3.2.0-60-generic-pae.
    DKMS will not replace this module.
    You may override by specifying --force.


    Backing up initrd.img-3.2.0-60-generic-pae to /boot/initrd.img-3.2.0-60-generic-pae.old-dkms
    Making new initrd.img-3.2.0-60-generic-pae

    done sucessfully but till the same problem

    i also having problem in installing DSP frimware i installed the software in windows while connecting the sranger i get driver not found and i could not get driver online.

  • Thorsten Wagner

    Thorsten Wagner - 2014-04-09

    As you have an SR-SP2 board you can use the Linux command loadusb64 to upload the DSP code to the boards. Just try:

    loadusb64 ./SRanger/TiCC-project-files/FB_spmcontrol/FB_spmcontrol.out

    (assuming that you have a ventiotec Distribution and not updating your code already from SVN). For Details on the loadusb64 tool have a look at the sranger-manual (chapter 4):

    For your convenience have also a look at the autoconf script which you will find in


    It will load automatically the DSP code to your board and set the offsets. Please check inside the script for the correct pathes. Due to major revisions of the code, not all links inside the code might be correct any more. If it is working fine you may copy it as root to /usr/bin so you can access it via the unity menu bar. In this case make sure that the offset and FB_spmcontroll.out files are in a Folder which can be accessed by the script.

    Thorsten :-)

  • dev renjith singh

    i have used from the pdf u gave me
    COFF2 Loader/Debugger for Signal Ranger MK2/USB-2.0
    20080311 Version 0.30, Copyright (C) 2002-2008 Percy Zahl
    Loadusb comes with ABSOLUTELY NO WARRANTY; for details type loadusb -W'. This is free software, and you are welcome to redistribute it under certain conditions; typeloadusb -W' for details.
    COFF file [.out]:
    Product: 0x1612
    Product: 0x0100
    --> B.Paillard, Signal Ranger MK2 Beta Version

    --> Checking DSP status...........: ioctl result=2
    --> Current DSP state is..........: 1
    --> DSP ready, setting HPI to fast: ioctl result=0

    MK2: no kernel load, no reset now.

    can't open file <.out>

    now how to upload dsp code

    Last edit: dev renjith singh 2014-04-11
  • Thorsten Wagner

    Thorsten Wagner - 2014-04-11

    You are using the laodusb for the mk2 aren't you. Please use the specific Version for the std/sp2 boards. You will find them in
    If there is no binary in These Folders please try to compile it via

    cd SRanger
    cd loadusb64

    and run it via

    cd ~/SRanger/loadusb64
    ./loadusb ../TiCC-project-files/FB_spmcontrol/FB_spmcontrol.out

    Please not the dot in front of the call of loadusb. That make sure that you run it from this Folder and not from /usr/bin or similar.

    Thorsten :-)

    • Cassiano Rabelo

      Cassiano Rabelo - 2014-04-16

      Hello Thorsten.
      It seems there was a bit of a confusing in this post. I (Cassiano) have a SR-SP2 and I started this thread. Mr. dev renjith later posted inside this same thread asking for the minidebugger. Apparently he has a MK2, but I'm not sure. I believe you thought that you were talking to me still, but you were talking to someone else with a distinct problem from the one that I had initially. :)
      Best regards,

  • dev renjith singh

    i used this
    $ cd ~/SRanger/TiCC-project-files/MK2-A810_FB_spmcontrol/python_scripts
    $ ./
    $ gxsm2 --force-configure
    Specify the correct hardware type, "SRangerMK2:SPM" and the device file "/dev/sranger_mk2_0".
    now its working thank you very much for your help


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks