SRanger on Ubuntu 11.04

  • Benedict Drevniok

    Hello, I am having some issues with a recent update to Ubuntu 11.04 _. Has
    anyone encountered anything like this? Any ideas welcome. I know that my Gxsm2
    has installed properly. I think the issues arise either during the SRanger
    install or the Kernel module install. If there is something else for my to
    include to help sort out what I might be missing, I can do that.


    nanophysics@pan:~/SRanger/modules-mk2-2.6.x$ make -C /usr/src/linux-headers-2.6.38-9-generic/ SUBDIRS=$PWD modules 
    make: Entering directory `/usr/src/linux-headers-2.6.38-9-generic'
      CC [M]  /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.o
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c:238:8: warning: type defaults to ‘int’ in declaration of ‘DECLARE_MUTEX’
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c:238:1: warning: parameter names (without types) in function declaration
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c:290:2: error: unknown field ‘ioctl’ specified in initializer
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c:290:2: warning: initialization from incompatible pointer type
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c: In function ‘sranger_mk2_probe’:
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c:1533:2: error: implicit declaration of function ‘init_MUTEX’
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c: At top level:
    /home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.c:238:8: warning: ‘DECLARE_MUTEX’ declared ‘static’ but never defined
    make[1]: *** [/home/nanophysics/SRanger/modules-mk2-2.6.x/usb-sranger_mk2.o] Error 1
    make: *** [_module_/home/nanophysics/SRanger/modules-mk2-2.6.x] Error 2
    make: Leaving directory `/usr/src/linux-headers-2.6.38-9-generic'




Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks