joystick issues

Help
2002-11-20
2013-04-03
  • Duncan Morison

    Duncan Morison - 2002-11-20

    right:

    got a usb dual firestorm plugged in.

    I have /dev/js0 in my controls for the gui off the startup options menu and the same in my controllers default option menu.

    the joypad works in the GUI but not in the games ( i.e. if I try and customise controls with TAB then when I press anything on the joypad the inputs do nothing )
    I have tried all the drivers including i386 and new i386 1.xx .

    this is on RedHat 8.0 with a stock kernel..... any ideas please?

     
    • Duncan Morison

      Duncan Morison - 2002-11-21

      when running GUI with joystick support:
      joydev 1

      when running GUI with joystick support:
      joydev 0

      when running the actual xmane app either with or w/out GUI joystick support:
      joydev 0

      so that would explain why it don't work.

      in the controllers preferences there are two options that allow me to point to /dev/js0 :
      i386 or new i386 1.xx

      others are:
      none
      FM town pad
      PS2 linux
      netbsd usb
      x11
      SDL

      tried them all and none will give me a joydev 1.

      xmms does actually work and also when starting xmame from gxmame it states as part of the startup:
      Message: xmame: I386 joystick interface initialization...
      Message: xmame: OSD: Warning: No joysticks found disabling joystick support

      when I start gxmame with joystick support I get:
      Message: Joystick THRUSTMASTER FireStorm Dual Power 2 found

      so what do you reckon:
      a) my system?
      b) gxmame passing bad values to xmame
      c) xmame
      d) mybad on configuring joystick ?

       
    • Nobody/Anonymous

      I kept getting the "Error: joytype 1 is not available"  So I looked at 'xmame-sdl --help' and it listed 0 for no joystick and 5 for SDL joystick. I had chosen SDL Joystick through the GUI, but that's when I got that error.  But if I changed ~/.gxmame/options/default to 'joytype=5' instead of 'joytype=1' then it worked flawlessly.  Now I have my gamepad working again!  (and it's the same one that you have!)  Best of luck.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks