No fullscreen in updated version

Help
2008-06-26
2013-04-26
  • Taylor Easum

    Taylor Easum - 2008-06-26

    The subject line says it all--after updating to 0.6.2, I can't get my games in fullscreen.  The options are even grayed out in the preferences dialog window.  I can start games via the command line in fullscreen mode with no problem.  Any suggestions?

     
    • Matthew Barnes

      Matthew Barnes - 2008-06-26

      Hi Taylor.  What version of xmame or sdlmame are you using?  Have you recently upgraded that as well?

      Also, can you try running these commands from a terminal window?  Type them exactly as shown.

          gnome-video-arcade --which-emulator

          `gnome-video-arcade --which-emulator` -showconfig | grep "window\|fullscreen"

      The preferences being grayed out tells me that GNOME Video Arcade isn't detecting support for the corresponding MAME command-line options.  These commands -- particularly the second one -- should give us an idea of what GVA is seeing.

       
      • Taylor Easum

        Taylor Easum - 2008-06-27

        Here's the output you requested

        :~$ gnome-video-arcade --which-emulator
        /usr/games/xmame

        :~$ `gnome-video-arcade --which-emulator` -showconfig | grep "window\|fullscreen"
        warning: no mixer plugins available
        info: trying to parse: /etc/xmame/xmamerc
        error: unknown option history_file, on line 13 of file: /etc/xmame/xmamerc
           ignoring line
        error: unknown option mameinfo_file, on line 14 of file: /etc/xmame/xmamerc
           ignoring line
        error: unknown option fuzzycmp, on line 33 of file: /etc/xmame/xmamerc
           ignoring line
        error: unknown option skip_disclaimer, on line 35 of file: /etc/xmame/xmamerc
           ignoring line
        info: trying to parse: /home/taylor/.xmame/xmamerc
        info: trying to parse: /etc/xmame/xmame-SDLrc
        info: trying to parse: /home/taylor/.xmame/xmame-SDLrc
        fullscreen              0

        I should mention that while using the previous version of GVA, I had no problems with the preferences dialog, and choosing between fullscreen and window display.

        Thanks for the help!
        -Taylor

         
    • Matthew Barnes

      Matthew Barnes - 2008-06-27

      I think those error messages about unknown options are confusing GVA into thinking the fullscreen option is not supported.  I tried adding those options to my own xmame config file and was able to reproduce the same grayed out check boxes that you're seeing.

      Try removing those lines from your /etc/xmame/xmamerc file.

       

Log in to post a comment.