#1 gnome-video-arcade 0.4.5.1 won't compile due to -Werror

closed
Compiling (1)
5
2007-09-21
2007-09-21
Chris Lord
No

gnome-video-arcade 0.4.5.1 won't compile due to -Werror and an unused variable:

gva-columns.c:773: warning: unused variable ‘iter'

I'll point out that it's a REALLY bad idea to put -Werror in a Makefile.am and that if you want to use it to keep yourself from introducing warnings that you should put it in your CFLAGS environment variable when you configure.

(some rationale for why it's a bad idea, warnings can differ per architecture/compiler and you have no way of testing every possible combination of targets that this could compile on).

Discussion

  • Matthew Barnes

    Matthew Barnes - 2007-09-21
    • status: open --> closed
     
  • Matthew Barnes

    Matthew Barnes - 2007-09-21

    Logged In: YES
    user_id=843448
    Originator: NO

    Point taken, I'll remove -Werror from future releases. Thanks for taking the time to report this.

     
  • Chris Lord

    Chris Lord - 2007-09-21

    Logged In: YES
    user_id=176104
    Originator: YES

    Thanks for attending to this so quickly, gva is a very nice app :)

     
  • Chris Lord

    Chris Lord - 2007-09-21
    • status: closed --> open
     
  • Matthew Barnes

    Matthew Barnes - 2007-09-21

    Logged In: YES
    user_id=843448
    Originator: NO

    Fix committed to revision 162.

     
  • Matthew Barnes

    Matthew Barnes - 2007-09-21
    • status: open --> closed
     
  • Matthew Barnes

    Matthew Barnes - 2007-09-21
    • assigned_to: nobody --> mfbarnes
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks