Weasel 1.59.5.cvs test available

1 2 > >> (Page 1 of 2)
  • John Gruenenfelder

    Greetings all!

    I've actually found a little time to work on Weasel.  Yes, I know... I'm scared too.

    This compiled version is from the current CVS.  Of course, being a Palm program, there are plenty of people who can't simply download and compile the CVS.  So here it is.

    Aside from a few minor issues, it's behaving well.  Virtually everything works on pre-OS5 devices that I know of.  Hi-res does *not* yet function properly on hi-res Sony OS4 devices.

    I think DIA support (i.e. virtual graffiti area) is working well, with possibly a few minor issues.

    Rotation on OS5... it works fine in the (piece of junk) OS5 simulator.  It does *NOT* work properly on my Clie TH-55, though it does not actually cause a crash.  I don't currently know about other OS5 devices.

    Since I've been away for a while it is hard to make sense of the many bug reports and which verisons they actually refer to.  Once I make an official 1.59.5 release I'm going to close all but the most concrete bugs in the SF bug database.  There have been huge display code changes since most of them were filed and so they are no longer valid and/or have been fixed already.

    So, with that... please try this new version on any and all devices you can.  As I said before, it should be nearly rock solid on pre-OS5 devices.  For OS5, it should at least be very usable.


    --John Gruenenfelder

    • Guillaume

      Guillaume - 2006-03-04

      Hi-res fonts, AND I can use the Find feature again!! Many kudos to you. I had a brief flirtation with other book readers and I actually use Plucker for special things like a mobile copy of The Onion, but I still love Weasel above all others.

      I did get a crash when I tried changing the font while I had a book open. With the book closed it worked just fine.

      The folder icon doesn't show any indication that you've clicked it, but it does take you to the index. Beats the heck out of the tiny back button in 1.59.3

      Last and minor is I can scroll through books on the index page with the five-way button, but can't select and open them.



      • John Gruenenfelder

        The font crash has been fixed.  You should be able to change fonts while reading now.

        The folder icon isn't actually a Palm OS "button" object, so it doesn't do the color inverting on its own.

        As for the 5-way button... The code is there to support it.  But, that came from a user supplied patch.  I currently have no way of testing the 5-way support at all.  I'm trying to get access to the PalmOne/Palm simulator binary which should have that.

        The way it *should* work is that up/down move the selection.  Left/right switch categories.  Select opens the selected book.  Which of these works?

        If only up/down are working it probably means that none of the 5-way is working properly and up/down are functioning simply because they operate the same as the up/down buttons on other Palm devices.

        I've replaced the weasel PRC from the above URL with the new copy which fixes the font change crash.

        --John Gruenenfelder

        • John Werner

          John Werner - 2006-03-06

          Looks nice.

          I am seeing the Font Crash with the latest version on my TJ37.  I am also running Font Hack V, so there may be some interference here.

          The other thing that caught me was the Options->Preferences item "Ignore DOC files."  It took me a few seconds to figure out that was why half the documents on my Clie disappeared.

          Thanks for the update,
          - John

    • John Gruenenfelder

      Hmmm... guess I should test things a bit more myself before I say anything.  Turns out that hi-res actually does work pretty well on OS4 Sony devices.  The status bar is a bit tiny, but still quite usable.

      --John Gruenenfelder

    • Guillaume

      Guillaume - 2006-03-06

      I'll download and install the new version this evening. I don't usually change fonts that much, only when I install a new version, or perform a hard reset and restore.

      The five way button will only allow me to scroll up and down, left and right do nothing.

      BTW, I'm running Weasel on a Tungsten E2, keeping all my books on on a 128 MB SD card. I have Backup and Destaller Pro, so it is very easy for me to uninstall and reinstall applications, if you need someone to test 5-Way button code.



      • John Gruenenfelder

        I finally regained access to the Palm "PluggedIn" developer program.  This let me download many of the different Palm simulators.  Unfortunately, unlike the Palm Emulator, the simulators all look alike and don't show any of the device specific hardware.  This means that even with the E2 simulator I don't see how I can actually test the 5-way button.  *sigh*

        But, I did dig around in the code some more and made a possible fix.  You can download the new binary at:

        That is the only change in this version versus the previous one.  Please let me know if the 5-way behaves any better.

        --John Gruenenfelder

        • Ruben Marquez

          Ruben Marquez - 2006-03-27

          It works!  I tried the march 24 version in my Tungsten E and the 5 way controller allowed me to open docs, scroll through them, open the bookmarks and select the desired one, and finally, close the doc.  Nice job and thank you.


    • skjef

      skjef - 2006-03-08

      I just tried the new version, I'm running a Sony Clie SJ-20 with OS4.1, and I'm experiencing a very large slowdown in page-turning. Something on the order of a little over a second between requesting a page turn and seeing the next page. I rolled back to 1.59.3, and it's about a tenth of a second.

      If you need any more specifics, just ask.

      Thanks for all your hard work on Weasel Reader, I love it.

      • John Gruenenfelder

        Not having an OS4 Sony device, this is a little hard for me to test.  It seems okay on the emulator, but of course that runs faster.

        What display options did you have enabled?  Were you using rotation?

        Do you have any hacks enabled?  If so, how does Weasel perform with hacks disabled?

        --John Gruenenfelder

    • Guillaume

      Guillaume - 2006-03-21

      I'm using the latest version of 1.59.5cvs, and I have noticed that the battery icon has disappeared from the status bar. Small thing, I know.

      Using a Tungsten E2.



      • John Gruenenfelder

        Hmmm... well, first I suppose the obvious questions:
        Did you have Weasel in fullscreen mode?  If not, had you perhaps tapped the battery icon so that it is instead displaying the battery percentage?

        Unfortunately, unlike the emulators, the Palm simulators all look essentially the same.  I suppose they're different inside...

        Do you have any hacks/etc. enabled?

        --John Gruenenfelder

    • Guillaume

      Guillaume - 2006-03-29

      I just installed the March 24, 2006 version last night.

      Tungsten E2:
      The five-way button doesn't work. It only allows me scroll, but won't select anything.

      No battery icon on the status bar. That is when I am displaying the status bar. Boohoo, but battery status is actually a hardware button away.

      No visible indicator that I'm selecting the back button to the folder view.

      Otherwise, I can read, find, and I have hi res fonts.



      • Guillaume

        Guillaume - 2006-03-29

        Oops. I forgot to mention: no hacks installed on my Tungsten E2.



    • jjmcgaffey

      jjmcgaffey - 2006-03-31

      Um.  I tried to install the March 3 version - I had great difficulty downloading it, and when I tried to install it it complained that the file was corrupted.  I was going to say something but in the meantime you put up the latest file - the March 24 one.  That one installed fine...except I didn't have any books.

      Most of my books are on a card, but I have some in memory - no difference, nothing visible in any category.  Oh, and trying to switch to a category I'd created (SF and SF - Flint were the two I tried) made it crash - Fatal exception and a reset button that didn't work - had to poke the back to reset it.  This happened 4-5 times.  I tried moving docs from card to RAM (with Filez) and back, checked which folders it was scanning in VFS Preferences, etc - no help, still not a document available. Reinstalled an earlier version (August 2004 is what it says in About) and all my docs are back, though I had to recategorize them.

      Tungsten T3, um...does Tealscript count as a hack?

      • John Gruenenfelder

        I'll look into the category crash.  Since you mentioned not having any books listed, did the category crash occur with no books listed?

        Somebody else mentioned that the setting to not show PalmDOC files seems to be on by default (is this true for everyone?).  Are your files PalmDOC or zTXT?  Maybe this is why they did not appear?

        --John Gruenenfelder

        • jjmcgaffey

          jjmcgaffey - 2006-04-01

          Yes, category crash happened with no books listed.  And yes, they're all doc files - hmmm, I'll try reloading with the latest Weasel and checking that option.  I didn't see it while I was searching for my books...

          Note that the default categories (Unlisted, Fiction, and All were the ones I tried) did _not_ crash - only the ones I'd created.

    • jjmcgaffey

      jjmcgaffey - 2006-04-01

      Ooookay!  I got the 'ignore DOC files' option unchecked - had to close and reopen Weasel - but now I have books - in the proper categories, even, and opening the categories doesn't cause a crash.  The books started opening with 90-degree rotation - but the Options:No Rotation choice fixed that.  However,  I tried going to the Display Prefs menu, and got a Fatal Alert - StringMgr.c, Line:128, NULL string passed.  This happens every time I try to open that menu.  The Reset button does work, though.   

    • Dennis McCunney

      Dennis McCunney - 2006-05-14

      Good heavens!  You *live*, and so does Weasel.  I had about given up hopes of an update.  Welcome back!

      I have the current version from CVS grabbed from your link.  It's installed on a Tapwave Zodiac 2, which is an OS 5.27 device with 320x480 screen and collapsable DIA.

      Weasel seems to work fine on it, uses the full screen, and behaves in portrait or landscape.  Rotation works, too. The only oddity is that the screen clears but does not refresh when rotating -- I get a blank screen until I tap it, whereupon it fills in.  I see similar behavior when I do something that changes screen size, like going into Preferences.  The DIA pops up to fill the space.  When I exit prefs and the DIA collapses, Weasel doesn't refresh the screen until I tap or scroll.

      Weasel does see docs on VFS volumes.  It also seems to handle multiple cards.  The Zodiac has two SD card slots, and Weasel found docs in configured directories on both cards.  The one thing that doesn't seem to work is the VFS browser. Invoking that does nothing.

      If the VFS Browser is intended to let you traverse the file system, it would be nice if it were integrated into the document list.

      I've also been using PalmFiction, another open source doc reader hosted on Source Forge.  (http://palmfiction.sourceforge.net) It's got a lot of neat features, but the home page and release notes are in Russian.  I had to stop at the 12c version because the 13 and 14 versions silently fail, but I have no way to tell why.

      PalmFiction will traverse the file system on cards and let you read doc files, text files, zText files, and RTF files (which it displays as plain text) from any location.  you might want to look at the source and see how it handles that.  It would be a good addition to Weasel.

      • Cormac McGaughey

        One other issue I noticed with the latest weasel on the Zodiac is that it doesn't always remember the screen orientation. The Zodiac has the ability to change its screen orientation from portrait to landscape.

    • Simon Norberg

      Simon Norberg - 2006-05-23

      Using Weasle 20060324 and its working grate on my m125 except the scrolling when going up or down I'm dont get a entire screen up or down like in Weasle 1.59.3 im geting an entire screen minus one row.

      • jjmcgaffey

        jjmcgaffey - 2006-05-23

        Look at the Scrolling Preferences - bet you've got them set to 'One Page with Context' - which means leave a line from the previous page showing.  Set it to 'One Page' and you'll get the whole page (that's what I have).

        • Simon Norberg

          Simon Norberg - 2006-05-23

          At scrolling preference Scrolling is set to: Up/Down a Page.

    • Roger Durańona Vargas

      Link isnt working

    • Aunty Sue

      Aunty Sue - 2006-07-01

      Hi, I'm thinking of helping to beta test this on my brand new LifeDrive. This is my first handheld, but I'm quite comfortable with computers in general (unix admin).

      So, is it likely to work at least somewhat on this model? Apart from syncing first and backing up that data, are there any other precautions or tools I should add first?

1 2 > >> (Page 1 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks