Weasel Test #1 available

2004-08-15
2013-04-17
1 2 > >> (Page 1 of 2)
  • John Gruenenfelder

    The first test release of Weasel Reader is available now.  I would definitely appreciate any testing you all may be able to do.

    What's good/new:
    * Should behave properly on all old devices and on all OS5 devices.  Should look correct on OS5 now.
    * All the various display modes should behave properly.
    * Rotation support has been *removed*.  It only worked on old-style display hardware, only in B&W, and only on square displays.  So... it was becoming less and less useful.  Perhaps if I have time I might look into code that can rotate newer displays.

    What I already know is broken:
    * Does not work well on pre-OS5 Sony devices.  It will work, but the text display occupies only 1/4 of the screen.
    * Many forms display improperly on Handera devices.

    So... give it a whirl.  That's all I think is wrong with it... maybe that's all that really *is* wrong with it.  :)

    You can find the test copy at:
      http://bach.as.arizona.edu/~johng/weasel/weasel-english.prc

    It will report itself variously as 1.59.4 or 1.59.5.  Internally, though, it is version 1.59.4 so that when 1.59.5 really is released, the preferences will be properly changed.

    --John Gruenenfelder

     
    • David Mehrmann

      David Mehrmann - 2004-08-16

      By the way, I'm also quite skilled at creating small icons, though I would need to know what icons are needed and their dimensions, aside from colour depth. Should you need some more than already offered, send me some email to jammet AT tigress.com.

      I'm using a Sony SL-10 which is hires but also greyscale so I'll probably not try this test version yet, as I'm still reading an ebook =) and doing this on a quarter of the screen doesn't sound so fun.

      Please bring back screen rotation sometime, it was great to have that.

       
    • Michiel Scholten

      Some minor bugs at my Sony TH-55 320x480 machine:
      - VFS Preferences window displays the Delete button a bit too much to the right [tends to go off the screen]
      - Switching between 320x320 and 320x480 mode doesn't work as espected [with the PalmOS arrow button in the lower right]. It automagically switched to use the full screen at a time. Thanks for supporting this btw :)
      - If in 320x480, the library is 320x320 and text appears in the region beneath it [where the silkscreen is supposed to be] - maybe library should take up the full height as well?
      - "Find" in the Library just crashed my Sony twice
      - Jump to location: "Bottom" button goes off screen
      - Progress bar seems jagged at the end instead of showing some lighter shade of gray or something
      - Weasel icon isn't hires in the various launchers I tested

      I didn't want to file these bugs in the bugtracker because they are in this beta. I hope I've provided you with some useful information to make Weasel even better. I very much appreciate the way Weasel already has improved at my platform - it stays my default ebook reader. Thanks for your time!

       
    • Lebrun

      Lebrun - 2004-08-18

      I just tested the new version on my Zire 31, and everything seems to be ok, with no display problems at all. I'll continue testing it, to check any posible bugs.

      BTW, I like the new icon.

       
    • Hans-Hermann Redenius

      on my clie TJ 35
      The battery button ist always black and the text in the top of the screen above the button goes white.

      Thanks for the program

       
    • Vladimir Zvezda

      Vladimir Zvezda - 2004-08-30

      On Zodiac I see an empty screen when open book. Had no success trying to change display settings.

      On Zire71 everything seems to be ok!

       
    • Choisum

      Choisum - 2004-08-30

      Works great on my Tungsten E with Chinese Support. Just one request, would it be possible to for Weasel to remember the copy setting?

      Many thanks for a great program.

       
    • Hawkeye

      Hawkeye - 2004-08-31

      I am using a Clie T615 so definitely waiting for the next version. But this is a great software. One function I would like to see in the future is the instant lookup function (i.e.support to PPI as in Plucker). That will be very helpful. Thanks.

       
    • Dave Pearson

      Dave Pearson - 2004-08-31

      I'm using a Tungsten|C with release 03 of the EFIGS biosn and the latest ARM zlib. When searching in the new weasel beta I get a

      Fatal Alert
      Emul68KMain.c,Line:403, illegal instruction 0008 at address 00503B2C

      I'm not sure what's causing this but on the grounds that the zlib is ARM code I'm guessing weasel knows :)

       
    • Choisum

      Choisum - 2004-08-31

      > instant lookup function (i.e.support to PPI as in
      > Plucker)

      If you should decide to implement the instant lookup function, please make it optional and please, please keep the copy mode.

      Plucker doesn't work right for Chinese (Japanese) text because there are no spaces to help identify word boundaries so the authors decided to only select a single character. This is equivalent to selecting the first two letters in an English word!!

      Many Thanks.

       
    • jjmcgaffey

      jjmcgaffey - 2004-09-02

      On my Tungsten T3, I get the same errors Aquatix got on the TH55 - except that I don't get full screen mode at all.  The full-screen arrow in the lower right is grayed out in both reading and library modes.

      I've also been using a variant version of Weasel that works with a DRM module - modified by Greg Weeks - for Embiid books.  I'll be asking him if he's willing to modify the more current version.  I don't think this is important until you have a complete version - but I thought you might be interested to know about it.

       
      • John Gruenenfelder

        The DIA (Dynamic Input Area) problem you are having on your T3 should be fixed now in the current CVS code.  DIA may not yet work entirely correctly, but it should at least be enabled.

        Also, on T3 devices (and only on those) you actually need some additional PRCs installed for DIA to function properly.  I don't know if Palm makes them easily available on their website or not.  I cannot include them with Weasel because of licensing issues, but I will put a copy of them on the website for people to download (with a link in the README).

        As for the DRM modules, Greg Weeks contacted me a while back about merging this code into Weasel.  It is actually present now.  However, in my version of Weasel, it is not enabled by default.  If you compile the source yourself, you can choose to compile in DRM support.  Since the code is still present, I suspect that when I make the next official release, Mr. Weeks will also present a DRM-enabled version of Weasel on his site.

        --John Gruenenfelder

         
        • Lebrun

          Lebrun - 2004-09-17

          I really wish you would make a separate build available without DRM. I don't really see a reason for an open source project to support any form of DRM, since all DRM is about is giving the user less and less choice.
          I for one don't buy or use any content and / or software wich uses DRM.

          Just my $0.02 worth.

           
          • John Gruenenfelder

            You should reread the post you are replying to.  What you suggest is what I am already doing.  There is *NO* DRM the compiled PRCs of Weasel that I offer on Sourceforge or the test builds I have elsewhere.

            To restate:  Mr. Weeks added DRM support to CSpotRun and as it is no longer maintained, he created a patch to add that support to Weasel.  Rather than maintain his own "fork", he asked to put the code into my CVS.  It was a small patch.

            I agreed on the condition that it would not be enabled by default and that I personally would not distribute a binary with it turned on.  He agreed and here we are now.

            The DRM in question is essentially just alternate methods of encoding PalmDOC format books.  The DRM code will, when such a book is opened, pass it through the appropriate filter (if you have them installed).  It also disables the excerpt feature and limits the amount of text you can select/copy on DRM protected books.

            So, even if you accidentally turned on the DRM when you compiled Weasel, you probably wouldn't even notice unless you were reading one of the DRM books.

            My views on the issue are actually quite similar to yours.  That is why the code is not enabled by default.

            --John Gruenenfelder

             
      • Michiel Scholten

        Actually, I could only get Weasel to show up full screen when launched from Zlauncher [note that the arrow button was grayed out]. However, with every other launcher I've tested, it shows up as 320x320 screen, with the arrow grayed out and the silkscreen showed as normal.

        I'm looking forward to a new [test]release. For the time being: reading with 320x320 isn't that bad either ;)

        Keep up this great work!

         
    • Ken

      Ken - 2004-09-05

      "Find" function in my Tungsten E causes it to freeze, making a reset necessary.  And the battery icon shows full even though it's not.  Othewise, it looks great. Thanks.

       
      • John Werner

        John Werner - 2004-09-13

        I am seeing both lockups and crashes ("Fatal Exception") when trying to use find on my Clie TJ37.  It does not seem to matter if the document is in internal RAM or on my memory stick.

        Other then that, I think it is looking pretty good.

        There is one other feature I would love snuck into the next release - something in the documents lists to tell me what is internal and what is on VFS.

        - John

         
        • Matija Nalis

          Matija Nalis - 2004-09-27

          Had the same problem with Find rebooting VisorPro here after installing the beta.
          It seems to be related to preferences size change 9or something). You need to completely erase weasel from launcher (backup the E-books first!) and then install beta and find will work correctly

           
    • Balabanov Dmitry

      it does not work on my HiRes sony clie device...
      text in the left upper coner

       
      • Egor Grebnev

        Egor Grebnev - 2004-11-02

        The same problem on my SJ20. I tried to play with the settings, but it did not help.

         
    • MedO

      MedO - 2004-09-28

      The FIND function also crashes my Palm m100, Palm OS 3.5.3. It creates a fatal exception.

       
    • jjmcgaffey

      jjmcgaffey - 2004-09-29

      The DIA looks fine now - nothing blacked out, or anything - and it works for entering Graffitti shortcuts.  However, the full-screen button is still greyed out and it won't go to full screen.  I have the two files - needed them for other programs.

      As Aquatix said - reading in 320x320 isn't bad.  And it looks just gorgeous.

      Thanks for making the DRM available - I'll be getting it from Greg Weeks when this version is finished.  Theoretically I dislike DRM - it's certainly more of a pain than the Gutenberg or Baen texts - but a pair of my favorite authors publish their books through Embiid with DRM and I _have_ to have them.  Stupid - open publishing would have got them at least two more readers (my parents) who tend to buy the books both hard-copy and electronically - but that's their choice.  And mine is not to miss their books.

       
      • Greg Weeks

        Greg Weeks - 2004-09-30

        I still need to get the dpad stuff to do a complete build. I left all of that out of the 1.59.3 beta. I've got the latest prc-tools built and have grabbed a couple of CVS snapshots and built them. There should be an Embiid DRM enabled build fairly soon after an official release.

         
    • jjmcgaffey

      jjmcgaffey - 2004-09-29

      Oh, another button sliding off the screen to the right - Delete in Edit Categories in the library.

       
    • William Hyatt

      William Hyatt - 2004-11-11

      First, I'd like to thank you John Gruenenfelder for this wonderful reader. A long long time ago I asked you to compile me a compact version of your reader without VFS for my old palm V with 2 megs of memory. I've used that constantly, hours a week since then. When I read a paperback I usually read 100 pages an hour, so you can imagine how much I've used your reader program. And I love it. That version didn't have scrolling fixed, but I used that thing constantly. Well I finally got around to upgrading and I've got a palm m500 now. I went to your homepage and got the test version from there.

      I've found a 100% reprodicible fatal error on my palm m500. First open up any menu bar while listing the books. Then tap twice (or try drawing something twice) in the area where you draw letters or numbers. Bang, Fatal Error. If I open a menu and then decide I dont want to choose anything and yet want to close the menu I often tap in that area to close the menu. While reading the text it seems to work fine, its just in the index that it doesn't work.

      Anyway keep up the great work. I love your reader!

       
1 2 > >> (Page 1 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks